summaryrefslogtreecommitdiff
path: root/modules/pam_exec/Makefile.am
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-01-24 16:02:11 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-01-24 16:02:11 +0000
commitc14d282c2a5fefbf7060d05b9d1910b359a1566f (patch)
tree8f6b2a2f2d2d4ac3462bf95487e9fde2d973e454 /modules/pam_exec/Makefile.am
parentfe200c2c6b75da02f6367c1d63d40b2304ed71d4 (diff)
CVS: Indicate any relevant BUGIDs here
Relevant BUGIDs: Purpose of commit: new feature Commit summary: --------------- 2006-01-24 Thorsten Kukuk <kukuk@thkukuk.de> * configure.in: Add modules/pam_exec. * modules/Makefile.am: Add pam_exec subdirectory. * modules/pam_exec/README: New. * modules/pam_exec/Makefile.am: New. * modules/pam_exec/pam_exec.8: New. * modules/pam_exec/pam_exec.c: New. * modules/pam_exec/pam_exec.8.xml: New. * po/POTFILES.in: Add modules/pam_exec/pam_exec.c. * po/*.po: Merge new pam_exec strings.
Diffstat (limited to 'modules/pam_exec/Makefile.am')
-rw-r--r--modules/pam_exec/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/modules/pam_exec/Makefile.am b/modules/pam_exec/Makefile.am
new file mode 100644
index 00000000..8310f3b6
--- /dev/null
+++ b/modules/pam_exec/Makefile.am
@@ -0,0 +1,21 @@
+#
+# Copyright (c) 2006 Thorsten Kukuk <kukuk@suse.de>
+#
+
+CLEANFILES = *~
+
+EXTRA_DIST = README $(MANS)
+
+man_MANS = pam_exec.8
+
+securelibdir = $(SECUREDIR)
+secureconfdir = $(SCONFIGDIR)
+
+AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include
+AM_LDFLAGS = -no-undefined -avoid-version -module \
+ -L$(top_builddir)/libpam -lpam
+if HAVE_VERSIONING
+ AM_LDFLAGS += -Wl,--version-script=$(srcdir)/../modules.map
+endif
+
+securelib_LTLIBRARIES = pam_exec.la