summaryrefslogtreecommitdiff
path: root/modules/pam_exec/Makefile.am
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-01-24 23:28:31 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-01-24 23:28:31 +0000
commit8d5b793b25a66e6657f5fdbeab96e1feac0d56af (patch)
treebbf4487e537da00949fb92a413137425e80c6187 /modules/pam_exec/Makefile.am
parentc14d282c2a5fefbf7060d05b9d1910b359a1566f (diff)
Relevant BUGIDs:
Purpose of commit: new feature Commit summary: --------------- Add framework for manpages in xml source Fix --enable-static-modules 2006-01-24 Thorsten Kukuk <kukuk@thkukuk.de> * libpam/pam_static_modules.h: New. * Makefile.am: Reorder subdirectories for static modules. * configure.in: Add --enable-static-modules option. * libpam/Makefile.am: Define WITH_SELINUX and WITH_PWDB if necessary, add pam_static_modules.h, link against all PAM module object files if STATIC_MODULES is defined. * libpam/pam_static.c: Remove old _static_module* includes, include pam_static_modules.h. * configure.in: Add checks for xsltproc, xmllint and docbook xsl stylesheet. * m4/jh_path_xml_catalog.m4: New.
Diffstat (limited to 'modules/pam_exec/Makefile.am')
-rw-r--r--modules/pam_exec/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/modules/pam_exec/Makefile.am b/modules/pam_exec/Makefile.am
index 8310f3b6..e67013d1 100644
--- a/modules/pam_exec/Makefile.am
+++ b/modules/pam_exec/Makefile.am
@@ -4,9 +4,10 @@
CLEANFILES = *~
-EXTRA_DIST = README $(MANS)
+EXTRA_DIST = README $(MANS) $(XMLS)
man_MANS = pam_exec.8
+man_XMLS = pam_exec.8.xml
securelibdir = $(SECUREDIR)
secureconfdir = $(SCONFIGDIR)
@@ -19,3 +20,14 @@ if HAVE_VERSIONING
endif
securelib_LTLIBRARIES = pam_exec.la
+
+if ENABLE_REGENERATE_MAN
+
+pam_exec.8: pam_exec.8.xml
+ $(XMLLINT) --nonet --xinclude --postvalid --noout $<
+ $(XSLTPROC) --nonet http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
+
+#CLEANFILES += $(man_MANS)
+
+endif
+