summaryrefslogtreecommitdiff
path: root/modules/pam_exec
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-02-07 07:51:13 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-02-07 07:51:13 +0000
commit8fa87c2931a1f25e4d2a851385b18759f7e6fde9 (patch)
tree66831670c2c8efff5964fc2f238f498d0c6cbf38 /modules/pam_exec
parent22e4ed7f49e0f7db1e29b15923d54a7798a1a2aa (diff)
Relevant BUGIDs:
Purpose of commit: new feature Commit summary: --------------- 2006-02-07 Thorsten Kukuk <kukuk@thkukuk.de> * configure.in: Check for text browser. * Make.xml.rules: Add rule to generate README from README.xml. * modules/pam_access/Makefile.am: Include Make.xml.rules. * modules/pam_access/README: Regenerated from README.xml. * modules/pam_access/README.xml: New. * modules/pam_access/access.conf: Extended by new examples. * modules/pam_access/access.conf.5: New, generated from xml file. * modules/pam_access/access.conf.5.xml: New. * modules/pam_access/pam_access.8: New, generated from xml file. * modules/pam_access/pam_access.8.xml: New. * modules/pam_access/pam_access.c: Add rules for IPv6 and netmasks. Based on patch from Mike Becher <Mike.Becher@lrz-muenchen.de>. * modules/pam_deny/Makefile.am: Include Make.xml.rules. * modules/pam_deny/pam_deny.8.xml: New. * modules/pam_deny/pam_deny.8: New, generated from xml file. * modules/pam_deny/README.xml: New. * modules/pam_deny/README: Regenerated from xml file. * modules/pam_cracklib/Makefile.am: Include Make.xml.rules. * modules/pam_cracklib/pam_cracklib.8.xml: New. * modules/pam_cracklib/pam_cracklib.8: New, generated from xml file. * modules/pam_cracklib/README.xml: New. * modules/pam_cracklib/README: Regenerated from xml file. * modules/pam_exec/Makefile.am: Add rule to generate README. * modules/pam_exec/README: Regenerated from xml file. * modules/pam_exec/pam_exec.8: Regenerated from xml file. * modules/pam_exec/pam_exec.8.xml: Syntax files.
Diffstat (limited to 'modules/pam_exec')
-rw-r--r--modules/pam_exec/Makefile.am7
-rw-r--r--modules/pam_exec/README47
-rw-r--r--modules/pam_exec/pam_exec.82
-rw-r--r--modules/pam_exec/pam_exec.8.xml16
4 files changed, 45 insertions, 27 deletions
diff --git a/modules/pam_exec/Makefile.am b/modules/pam_exec/Makefile.am
index e7ecd591..3f3ef85c 100644
--- a/modules/pam_exec/Makefile.am
+++ b/modules/pam_exec/Makefile.am
@@ -4,7 +4,7 @@
CLEANFILES = *~
-EXTRA_DIST = README $(MANS) $(XMLS)
+EXTRA_DIST = README README.xml $(MANS) $(XMLS)
man_MANS = pam_exec.8
man_XMLS = pam_exec.8.xml
@@ -22,6 +22,11 @@ endif
securelib_LTLIBRARIES = pam_exec.la
if ENABLE_REGENERATE_MAN
+
+noinst_DATA = README
+
+README: pam_exec.8.xml
+
-include $(top_srcdir)/Make.xml.rules
endif
diff --git a/modules/pam_exec/README b/modules/pam_exec/README
index 8451ef03..8ff9a742 100644
--- a/modules/pam_exec/README
+++ b/modules/pam_exec/README
@@ -1,29 +1,42 @@
+pam_exec — PAM module which calls an external command
-pam_exec module:
- Call <prog> <arguments>
+━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
+DESCRIPTION
-USAGE:
- For the services you wish to run a program put the following
- line in the config as the last line for that service:
+pam_exec is a PAM module that can be used to run an external command.
- <type> required pam_exec.so [options] /path/prog ...
+OPTIONS
- and pam_exec.so will run "/path/prog ...".
+debug
+ Print debug information.
-OPTIONS:
+log=file
- debug print debug informations
+ The output of the command is appended to file
- seteuid pam_exec.so will call setuid(seteuid()), so that
- the program will run with the same rights as the
- calling applications (effective user ID). The
- default is that the program will be run with the
- permissions of the calling user (real user ID).
+seteuid
- log=<file> the output is appended to this file.
+ Per default pam_exec.so will execute the external command with the real
+ user ID of the calling process. Specifying this option means the command is
+ run with the effective user ID.
+EXAMPLES
+
+Add the following line to /etc/pam.d/passwd to rebuild the NIS database after
+each local password change:
+
+ passwd optional pam_exec.so seteuid make -C /var/yp
+
+
+This will execute the command
+
+make -C /var/yp
+
+with effective user ID.
+
+AUTHOR
+
+pam_exec was written by Thorsten Kukuk <kukuk@thkukuk.de>.
-AUTHOR:
- Thorsten Kukuk <kukuk@thkukuk.de>
diff --git a/modules/pam_exec/pam_exec.8 b/modules/pam_exec/pam_exec.8
index 96761ac6..be04b75e 100644
--- a/modules/pam_exec/pam_exec.8
+++ b/modules/pam_exec/pam_exec.8
@@ -2,7 +2,7 @@
.\" It was generated using the DocBook XSL Stylesheets (version 1.69.1).
.\" Instead of manually editing it, you probably should edit the DocBook XML
.\" source for it and then use the DocBook XSL Stylesheets to regenerate it.
-.TH "PAM_EXEC" "8" "01/30/2006" "Linux\-PAM Manual" "Linux\-PAM Manual"
+.TH "PAM_EXEC" "8" "02/03/2006" "Linux\-PAM Manual" "Linux\-PAM Manual"
.\" disable hyphenation
.nh
.\" disable justification (adjust text to left margin only)
diff --git a/modules/pam_exec/pam_exec.8.xml b/modules/pam_exec/pam_exec.8.xml
index 3b681cf2..c7241abe 100644
--- a/modules/pam_exec/pam_exec.8.xml
+++ b/modules/pam_exec/pam_exec.8.xml
@@ -10,7 +10,7 @@
<refmiscinfo class="sectdesc">Linux-PAM Manual</refmiscinfo>
</refmeta>
- <refnamediv>
+ <refnamediv id="pam_exec-name">
<refname>pam_exec</refname>
<refpurpose>PAM module which calls an external command</refpurpose>
</refnamediv>
@@ -38,7 +38,7 @@
<refsect1 id="pam_exec-description">
- <title>Description</title>
+ <title>DESCRIPTION</title>
<para>
pam_exec is a PAM module that can be used to run
@@ -49,7 +49,7 @@
<refsect1 id="pam_exec-options">
- <title>Options</title>
+ <title>OPTIONS</title>
<para>
<variablelist>
@@ -96,7 +96,7 @@
</refsect1>
<refsect1 id="pam_exec-services">
- <title>Module Services Provided</title>
+ <title>MODULE SERVICES PROVIDED</title>
<para>
The services <option>auth</option>, <option>account</option>,
<option>password</option> and <option>session</option> are supported.
@@ -104,7 +104,7 @@
</refsect1>
<refsect1 id='pam_exec-return_values'>
- <title>Return Values</title>
+ <title>RETURN VALUES</title>
<para>
<variablelist>
@@ -150,7 +150,7 @@
</refsect1>
<refsect1 id='pam_exec-examples'>
- <title>Examples</title>
+ <title>EXAMPLES</title>
<para>
Add the following line to <filename>/etc/pam.d/passwd</filename> to
rebuild the NIS database after each local password change:
@@ -165,7 +165,7 @@
</refsect1>
<refsect1 id='pam_exec-see_also'>
- <title>See Also</title>
+ <title>SEE ALSO</title>
<para>
<citerefentry>
<refentrytitle>pam.conf</refentrytitle><manvolnum>5</manvolnum>
@@ -180,7 +180,7 @@
</refsect1>
<refsect1 id='pam_exec-author'>
- <title>Author</title>
+ <title>AUTHOR</title>
<para>
pam_exec was written by Thorsten Kukuk &lt;kukuk@thkukuk.de&gt;.
</para>