summaryrefslogtreecommitdiff
path: root/modules/pam_group
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2009-12-08 14:41:40 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2009-12-08 14:41:40 +0000
commita728c0f63e15c18ef599e599e4e46456b624abda (patch)
tree8fb7df4028a6852952629510e88646e38cd3ae97 /modules/pam_group
parent17c4c04115c7de3f5884ebdc562b0912bbd1b736 (diff)
Relevant BUGIDs: 2892529
Purpose of commit: bugfix Commit summary: --------------- 2009-12-08 Thorsten Kukuk <kukuk@thkukuk.de> * configure.in: Rename DEBUG to PAM_DEBUG. * libpam/pam_env.c: Likewise * libpam/pam_handlers.c: Likewise * libpam/pam_miscc.c: Likewise * libpam/pam_password.c: Likewise * libpam/include/security/_pam_macros.h: Likewise * libpamc/test/modules/pam_secret.c: Likewise * modules/pam_group/pam_group.c: Likewise * modules/pam_listfile/pam_listfile.c: Likewise * modules/pam_unix/pam_unix_auth.c: Likewise * modules/pam_unix/pam_unix_passwd.c: Likewise
Diffstat (limited to 'modules/pam_group')
-rw-r--r--modules/pam_group/pam_group.c6
1 files changed, 3 insertions, 3 deletions
diff --git a/modules/pam_group/pam_group.c b/modules/pam_group/pam_group.c
index 4a931c4f..3dc7f78e 100644
--- a/modules/pam_group/pam_group.c
+++ b/modules/pam_group/pam_group.c
@@ -605,7 +605,7 @@ static int check_account(pam_handle_t *pamh, const char *service,
no_grps = 0;
_pam_drop(grps);
}
-#ifdef DEBUG
+#ifdef PAM_DEBUG
{
int z;
for (z=0; z<no_grps; ++z) {
@@ -719,11 +719,11 @@ static int check_account(pam_handle_t *pamh, const char *service,
/* now set the groups for the user */
if (no_grps > 0) {
-#ifdef DEBUG
+#ifdef PAM_DEBUG
int err;
#endif
D(("trying to set %d groups", no_grps));
-#ifdef DEBUG
+#ifdef PAM_DEBUG
for (err=0; err<no_grps; ++err) {
D(("gid[%d]=%d", err, grps[err]));
}