summaryrefslogtreecommitdiff
path: root/modules/pam_lastlog/Makefile.am
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-06-01 19:56:22 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-06-01 19:56:22 +0000
commit29a98911d9cb5e9187c1afe4e161c6861fac4f2b (patch)
tree5a87fc7d53de366e57281cf035f2519acad811c0 /modules/pam_lastlog/Makefile.am
parent136a7d4dd5055f96c5ca59cefd290f828c6decbd (diff)
Relevant BUGIDs:
Purpose of commit: new feature Commit summary: --------------- 2006-06-01 Thorsten Kukuk <kukuk@thkukuk.de> * modules/pam_lastlog/Makefile.am: Include Make.xml.rules. * modules/pam_lastlog/pam_lastlog.8.xml: New. * modules/pam_lastlog/pam_lastlog.8: New, generated from xml file. * modules/pam_lastlog/README.xml: New. * modules/pam_lastlog/README: Regenerated from xml file.
Diffstat (limited to 'modules/pam_lastlog/Makefile.am')
-rw-r--r--modules/pam_lastlog/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/modules/pam_lastlog/Makefile.am b/modules/pam_lastlog/Makefile.am
index 73ee4be6..e81e7833 100644
--- a/modules/pam_lastlog/Makefile.am
+++ b/modules/pam_lastlog/Makefile.am
@@ -7,7 +7,10 @@ CLEANFILES = *~
securelibdir = $(SECUREDIR)
secureconfdir = $(SCONFIGDIR)
-EXTRA_DIST = README tst-pam_lastlog
+EXTRA_DIST = README $(MANS) $(XMLS) tst-pam_lastlog
+
+man_MANS = pam_lastlog.8
+XMLS = README.xml pam_lastlog.8.xml
TESTS = tst-pam_lastlog
@@ -19,3 +22,10 @@ if HAVE_VERSIONING
endif
securelib_LTLIBRARIES = pam_lastlog.la
+
+if ENABLE_REGENERATE_MAN
+noinst_DATA = README
+README: pam_lastlog.8.xml
+-include $(top_srcdir)/Make.xml.rules
+endif
+