summaryrefslogtreecommitdiff
path: root/modules/pam_lastlog
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-02-22 18:19:25 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-02-22 18:19:25 +0000
commit0babf02dcc33b6c727811fb70399b4a9979edf32 (patch)
tree5d53ea887de9202963c0038b8dbd3027452e1fed /modules/pam_lastlog
parenta6a981f6c746bf27da9fab021baee009c049d4d5 (diff)
Relevant BUGIDs: 1427401
Purpose of commit: bugfix Commit summary: --------------- 2006-02-22 Thorsten Kukuk <kukuk@thkukuk.de> * configure.in: Fix check for incomplete libaudit installations (Patch from Ruediger Oertel <ro@suse.de>) * modules/pam_lastlog/pam_lastlog.c (last_login_write): Initialize correct last_login field [#1427401]
Diffstat (limited to 'modules/pam_lastlog')
-rw-r--r--modules/pam_lastlog/pam_lastlog.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/pam_lastlog/pam_lastlog.c b/modules/pam_lastlog/pam_lastlog.c
index 24a13ef6..7e635335 100644
--- a/modules/pam_lastlog/pam_lastlog.c
+++ b/modules/pam_lastlog/pam_lastlog.c
@@ -274,7 +274,7 @@ last_login_write(pam_handle_t *pamh, int announce, int last_fd,
terminal_line = get_tty(pamh);
/* copy to last_login */
- last_login.ll_host[0] = '\0';
+ last_login.ll_line[0] = '\0';
strncat(last_login.ll_line, terminal_line, sizeof(last_login.ll_line)-1);
terminal_line = NULL;