summaryrefslogtreecommitdiff
path: root/modules/pam_listfile
diff options
context:
space:
mode:
authorTomas Mraz <tmraz@fedoraproject.org>2019-12-18 13:55:23 +0100
committerTomas Mraz <tmraz@fedoraproject.org>2019-12-18 13:59:44 +0100
commit1781f0165c6f83601088f47681a05956ad9c21e1 (patch)
treefca2caff5fac43bad7f657f81c7a2a1b3df2ab62 /modules/pam_listfile
parent73118592885eb3554eddb360d5f6ab65ee6e1c03 (diff)
Do not use CFLAGS for warning flags set from configure
To be able to set CFLAGS from make command-line but not to lose the warning flags. * configure.ac: Put warning flags to WARN_CFLAGS instead of CFLAGS. * */Makefile.am: Apply WARN_CFLAGS to AM_CFLAGS.
Diffstat (limited to 'modules/pam_listfile')
-rw-r--r--modules/pam_listfile/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/modules/pam_listfile/Makefile.am b/modules/pam_listfile/Makefile.am
index 7b10af98..85396a03 100644
--- a/modules/pam_listfile/Makefile.am
+++ b/modules/pam_listfile/Makefile.am
@@ -15,7 +15,8 @@ TESTS = tst-pam_listfile
securelibdir = $(SECUREDIR)
secureconfdir = $(SCONFIGDIR)
-AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include
+AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include \
+ $(WARN_CFLAGS)
AM_LDFLAGS = -no-undefined -avoid-version -module
if HAVE_VERSIONING
AM_LDFLAGS += -Wl,--version-script=$(srcdir)/../modules.map