summaryrefslogtreecommitdiff
path: root/modules/pam_namespace/Makefile.am
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@altlinux.org>2020-04-26 19:40:57 +0000
committerDmitry V. Levin <ldv@altlinux.org>2020-04-26 19:40:57 +0000
commit46eb2b06c6c86c56e1c485b10019d7f3b2d268c5 (patch)
treef04ceb411343ef75d497dcb8c408096b39508ed1 /modules/pam_namespace/Makefile.am
parent276bd9a38b879e979e3e5b38639c5298f5dd1c11 (diff)
build: move pam_namespace build condition to modules/Makefile.am
* configure.ac (AM_CONDITIONAL): Replace HAVE_UNSHARE with COND_BUILD_PAM_NAMESPACE. * modules/Makefile.am [COND_BUILD_PAM_NAMESPACE] (MAYBE_PAM_NAMESPACE): Define. (SUBDIRS): Replace pam_namespace with $(MAYBE_PAM_NAMESPACE). * modules/pam_namespace/Makefile.am: Assume HAVE_UNSHARE.
Diffstat (limited to 'modules/pam_namespace/Makefile.am')
-rw-r--r--modules/pam_namespace/Makefile.am20
1 files changed, 8 insertions, 12 deletions
diff --git a/modules/pam_namespace/Makefile.am b/modules/pam_namespace/Makefile.am
index d3ad23d4..7f75ff28 100644
--- a/modules/pam_namespace/Makefile.am
+++ b/modules/pam_namespace/Makefile.am
@@ -13,10 +13,8 @@ endif
EXTRA_DIST = README namespace.conf namespace.init $(MANS) $(XMLS) tst-pam_namespace
-if HAVE_UNSHARE
- TESTS = tst-pam_namespace
- man_MANS = $(MAN5) $(MAN8)
-endif
+TESTS = tst-pam_namespace
+man_MANS = $(MAN5) $(MAN8)
XMLS = README.xml namespace.conf.5.xml pam_namespace.8.xml pam_namespace_helper.8.xml
@@ -34,24 +32,22 @@ endif
noinst_HEADERS = md5.h pam_namespace.h argv_parse.h
-if HAVE_UNSHARE
- securelib_LTLIBRARIES = pam_namespace.la
- pam_namespace_la_SOURCES = pam_namespace.c md5.c argv_parse.c
- pam_namespace_la_LIBADD = $(top_builddir)/libpam/libpam.la @LIBSELINUX@
+securelib_LTLIBRARIES = pam_namespace.la
+pam_namespace_la_SOURCES = pam_namespace.c md5.c argv_parse.c
+pam_namespace_la_LIBADD = $(top_builddir)/libpam/libpam.la @LIBSELINUX@
- secureconf_DATA = namespace.conf
- secureconf_SCRIPTS = namespace.init
+secureconf_DATA = namespace.conf
+secureconf_SCRIPTS = namespace.init
install-data-local:
mkdir -p $(DESTDIR)$(namespaceddir)
mkdir -p $(DESTDIR)$(servicedir)
$(INSTALL_DATA) pam_namespace.service $(DESTDIR)$(servicedir)
- sbin_SCRIPTS = pam_namespace_helper
+sbin_SCRIPTS = pam_namespace_helper
uninstall-local:
-rm $(DESTDIR)$(servicedir)/pam_namespace.service
-endif
if ENABLE_REGENERATE_MAN