summaryrefslogtreecommitdiff
path: root/modules/pam_selinux/pam_selinux_check.c
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@altlinux.org>2005-11-24 17:15:31 +0000
committerDmitry V. Levin <ldv@altlinux.org>2005-11-24 17:15:31 +0000
commitb3a154da2130f03f86973eaee90434f99fa2ab7a (patch)
tree2db7a55669b25d8903e262f2b25f1da40b05e6c7 /modules/pam_selinux/pam_selinux_check.c
parentdc1ef1998cff01323a93ee312f638cf4ba45c794 (diff)
Relevant BUGIDs: none
Purpose of commit: cleanup Commit summary: --------------- 2005-11-24 Dmitry V. Levin <ldv@altlinux.org> * configure.in: Do not check for strerror. * libpam_misc/misc_conv.c (read_string): Replace strerror() call with %m specifier. * libpamc/pamc_converse.c (pamc_converse): Likewise. * modules/pam_echo/pam_echo.c (pam_echo): Likewise. * modules/pam_localuser/pam_localuser.c (pam_sm_authenticate): Likewise. * modules/pam_selinux/pam_selinux.c (security_label_tty): Likewise. (security_restorelabel_tty, security_label_tty): Append %m specifier where appropriate. * modules/pam_selinux/pam_selinux_check.c (main): Replace strerror() call with %m specifier. * modules/pam_unix/pam_unix_passwd.c (save_old_password, _update_passwd, _update_shadow): Likewise. * modules/pam_unix/support.c (_unix_run_helper_binary): Likewise. * modules/pam_unix/unix_chkpwd.c (_update_shadow): Likewise. * po/Linux-PAM.pot: Update strings from pam_selinux. * po/cs.po: Likewise. * po/de.po: Likewise. * po/es.po: Likewise. * po/fi.po: Likewise. * po/fr.po: Likewise. * po/hu.po: Likewise. * po/it.po: Likewise. * po/ja.po: Likewise. * po/nb.po: Likewise. * po/pa.po: Likewise. * po/pl.po: Likewise. * po/pt.po: Likewise. * po/pt_BR.po: Likewise. * po/zh_CN.po: Likewise. * po/zh_TW.po: Likewise.
Diffstat (limited to 'modules/pam_selinux/pam_selinux_check.c')
-rw-r--r--modules/pam_selinux/pam_selinux_check.c4
1 files changed, 1 insertions, 3 deletions
diff --git a/modules/pam_selinux/pam_selinux_check.c b/modules/pam_selinux/pam_selinux_check.c
index 73c77fa0..30526d37 100644
--- a/modules/pam_selinux/pam_selinux_check.c
+++ b/modules/pam_selinux/pam_selinux_check.c
@@ -129,10 +129,8 @@ main (int argc, char **argv)
childPid = fork();
if (childPid < 0) {
- int errsv = errno;
-
/* error in fork() */
- fprintf(stderr, _("login: failure forking: %s"), strerror(errsv));
+ fprintf(stderr, _("login: failure forking: %m"));
pam_close_session(pamh, 0);
/* We're done with PAM. Free `pam_handle'. */
pam_end( pamh, PAM_SUCCESS );