summaryrefslogtreecommitdiff
path: root/modules/pam_shells/Makefile.am
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-06-06 16:03:10 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-06-06 16:03:10 +0000
commitdeda060dfbfb989de28235617fc3a9149aaee1e3 (patch)
treec8b19b160c7d85a47e0c69fcacc16f0c56d8402c /modules/pam_shells/Makefile.am
parent2f42cd380c92907ed8d6a45fc6cada3df900b4c2 (diff)
Relevant BUGIDs:
Purpose of commit: new feature Commit summary: --------------- 2006-06-06 Thorsten Kukuk <kukuk@thkukuk.de> * modules/pam_shells/Makefile.am: Include Make.xml.rules. * modules/pam_shells/pam_shells.8.xml: New. * modules/pam_shells/pam_shells.8: New, generated from xml file. * modules/pam_shells/README.xml: New. * modules/pam_shells/README: Regenerated from xml file.
Diffstat (limited to 'modules/pam_shells/Makefile.am')
-rw-r--r--modules/pam_shells/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/modules/pam_shells/Makefile.am b/modules/pam_shells/Makefile.am
index 06e1421b..03ac8b15 100644
--- a/modules/pam_shells/Makefile.am
+++ b/modules/pam_shells/Makefile.am
@@ -4,7 +4,10 @@
CLEANFILES = *~
-EXTRA_DIST = README tst-pam_shells
+EXTRA_DIST = README $(MANS) $(XMLS) tst-pam_shells
+
+man_MANS = pam_shells.8
+XMLS = README.xml pam_shells.8.xml
TESTS = tst-pam_shells
@@ -19,3 +22,10 @@ if HAVE_VERSIONING
endif
securelib_LTLIBRARIES = pam_shells.la
+
+if ENABLE_REGENERATE_MAN
+noinst_DATA = README
+README: pam_shells.8.xml
+-include $(top_srcdir)/Make.xml.rules
+endif
+