summaryrefslogtreecommitdiff
path: root/modules/pam_succeed_if/README
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-08-05 08:03:11 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-08-05 08:03:11 +0000
commit72bcf614b2a5e5f281ca4372fa7dfccf1e6a3c43 (patch)
treeee1821fdda266c77a0f4ae403fe4358e7c45a47d /modules/pam_succeed_if/README
parentea9255e046169e5d5b19370c9ae6292be5aacde0 (diff)
Relevant BUGIDs:
Purpose of commit: new feature Commit summary: --------------- Add xtests to allow checks for PAM functions only doable in installed system. 2006-08-05 Thorsten Kukuk <kukuk@thkukuk.de> * configure.in: Generate xtests/Makefile. * Makefile.am (SUBDIRS): Add xtests. * README: Document make check and make xtests. * xtests/Makefile.am: New. * xtests/tst-pam_dispatch1.pamd: New. * xtests/tst-pam_dispatch2.pamd: New. * xtests/tst-pam_dispatch3.pamd: New. * xtests/tst-pam_dispatch1.c: New. * xtests/tst-pam_dispatch2.c: New. * xtests/tst-pam_dispatch3.c: New.
Diffstat (limited to 'modules/pam_succeed_if/README')
-rw-r--r--modules/pam_succeed_if/README18
1 files changed, 17 insertions, 1 deletions
diff --git a/modules/pam_succeed_if/README b/modules/pam_succeed_if/README
index c8d2ceff..4516a9d1 100644
--- a/modules/pam_succeed_if/README
+++ b/modules/pam_succeed_if/README
@@ -38,7 +38,7 @@ quiet_success
Conditions are three words: a field, a test, and a value to test for.
-Available fields are user, uid, gid, shell and home:
+Available fields are user, uid, gid, shell, home and service:
field < number
@@ -80,6 +80,14 @@ field !~ glob
Field does not match the given glob.
+field in item:item:...
+
+ Field is contained in the list of items separated by colons.
+
+field notin item:item:...
+
+ Field is not contained in the list of items separated by colons.
+
user ingroup group
User is in given group.
@@ -88,6 +96,14 @@ user notingroup group
User is not in given group.
+user innetgr netgroup
+
+ (user,host) is in given netgroup.
+
+user notinnetgr group
+
+ (user,host) is not in given netgroup.
+
EXAMPLES
To emulate the behaviour of pam_wheel, except there is no fallback to group 0: