summaryrefslogtreecommitdiff
path: root/modules/pam_tally
diff options
context:
space:
mode:
authorAndrew G. Morgan <morgan@kernel.org>2001-06-27 06:20:42 +0000
committerAndrew G. Morgan <morgan@kernel.org>2001-06-27 06:20:42 +0000
commitac205ce13df8def522f386a922401ade673cb3a2 (patch)
treea325cd3f2ba77b6936512d6019b056641e2cca50 /modules/pam_tally
parent1e8bcb43e3f024f9303dc884ee8b445f4150142c (diff)
Relevant BUGIDs: 436432
Purpose of commit: cleanup Commit summary: --------------- small changes inspired by reading a red hat diff.
Diffstat (limited to 'modules/pam_tally')
-rw-r--r--modules/pam_tally/Makefile10
-rw-r--r--modules/pam_tally/pam_tally.c2
2 files changed, 7 insertions, 5 deletions
diff --git a/modules/pam_tally/Makefile b/modules/pam_tally/Makefile
index 7949b558..1c5106e3 100644
--- a/modules/pam_tally/Makefile
+++ b/modules/pam_tally/Makefile
@@ -67,8 +67,8 @@ $(LIBOBJD): $(LIBSRC)
$(LIBSHARED): $(LIBOBJD)
$(LD_D) -o $@ $(LIBOBJD)
-$(APPLICATION): $(APPOBJD)
- $(CC) $(CFLAGS) -o $@ $< $(LOADLIBES)
+$(APPLICATION): $(APPOBJD) $(TITLE).c
+ $(CC) $(CFLAGS) -o $@ $(APPOBJD) $(LOADLIBES)
endif
@@ -78,8 +78,8 @@ $(LIBOBJS): $(LIBSRC)
$(LIBSTATIC): $(LIBOBJS)
$(LD) -r -o $@ $(LIBOBJS)
-$(APPLICATION): $(APPOBJS)
- $(CC) $(CFLAGS) -o $@ $< $(LOADLIBES)
+$(APPLICATION): $(APPOBJS) $(TITLE).c
+ $(CC) $(CFLAGS) -o $@ $(APPOBJS) $(LOADLIBES)
endif
install: all
@@ -88,7 +88,7 @@ ifdef DYNAMIC
$(INSTALL) -m $(SHLIBMODE) $(LIBSHARED) $(FAKEROOT)$(SECUREDIR)
endif
$(MKDIR) $(FAKEROOT)$(SUPLEMENTED)
-# $(INSTALL) -m $(APPMODE) $(APPLICATION) $(FAKEROOT)$(SUPLEMENTED)
+ $(INSTALL) -m $(APPMODE) $(APPLICATION) $(FAKEROOT)$(SUPLEMENTED)
remove:
rm -f $(FAKEROOT)$(SECUREDIR)/$(TITLE).so
diff --git a/modules/pam_tally/pam_tally.c b/modules/pam_tally/pam_tally.c
index 3d994458..b5bbaba3 100644
--- a/modules/pam_tally/pam_tally.c
+++ b/modules/pam_tally/pam_tally.c
@@ -16,6 +16,7 @@
#include <stdio.h>
#include <string.h>
#include <unistd.h>
+#include <stdlib.h>
#include <stdarg.h>
#include <syslog.h>
#include <pwd.h>
@@ -84,6 +85,7 @@ static void _pam_log(int err, const char *format, ...)
#ifdef MAIN
vfprintf(stderr,format,args);
+ fprintf(stderr,"\n");
#else
openlog(MODULE_NAME, LOG_CONS|LOG_PID, LOG_AUTH);
vsyslog(err, format, args);