summaryrefslogtreecommitdiff
path: root/modules/pam_tally
diff options
context:
space:
mode:
authorAndrew G. Morgan <morgan@kernel.org>2000-11-19 23:54:01 +0000
committerAndrew G. Morgan <morgan@kernel.org>2000-11-19 23:54:01 +0000
commit73346dba777b023e46830a973148eb0ddbf8f8b4 (patch)
tree3ac12799a597cb2004f8ebf5b18a4469ccee9a44 /modules/pam_tally
parent47575925596c2af2a78c009fcdd14de72fc82d3e (diff)
Relevant BUGIDs: task 15788, bugs 108297, 117476, 117474
Purpose of commit: autoconf support for Linux-PAM Commit summary: --------------- This is a merge of the autoconf support that was developed against a 0-72 branch. [Note, because CVS has some issues, this is actually only 95% of the actual commit. The other files were actually committed when the preparation branch Linux-PAM-0-73pre-autoconf was updated. Hopefully, this will complete the merge.]
Diffstat (limited to 'modules/pam_tally')
-rw-r--r--modules/pam_tally/Makefile14
-rw-r--r--modules/pam_tally/pam_tally.c7
2 files changed, 7 insertions, 14 deletions
diff --git a/modules/pam_tally/Makefile b/modules/pam_tally/Makefile
index 78ce621d..7949b558 100644
--- a/modules/pam_tally/Makefile
+++ b/modules/pam_tally/Makefile
@@ -7,6 +7,8 @@
#
#
+include ../../Make.Rules
+
TITLE=pam_tally
#
@@ -44,14 +46,7 @@ APPMODE = 755
####################### don't edit below #######################
-dummy:
- @echo "**** This is not a top-level Makefile "
- exit
-
-all: dirs $(LIBSHARED) $(LIBSTATIC) register
-# we're not yet in a position to build this. If you want it, build it
-# separately...
-# $(APPLICATION)
+all: dirs $(LIBSHARED) $(LIBSTATIC) register $(APPLICATION)
dirs:
ifdef DYNAMIC
@@ -101,9 +96,8 @@ remove:
clean:
rm -f $(LIBOBJD) $(LIBOBJS) $(APPOBJD) $(APPOBJS) core *~
-
-extraclean: clean
rm -f *.a *.o *.so *.bak dynamic/* static/* $(APPLICATION)
+ rm -rf dynamic static
.c.o:
$(CC) $(CFLAGS) -c $<
diff --git a/modules/pam_tally/pam_tally.c b/modules/pam_tally/pam_tally.c
index ff75697d..436ce956 100644
--- a/modules/pam_tally/pam_tally.c
+++ b/modules/pam_tally/pam_tally.c
@@ -11,10 +11,7 @@
* Stuff stolen from pam_rootok and pam_listfile
*/
-#ifdef linux
-# define _GNU_SOURCE
-# include <features.h>
-#endif
+#include <security/_pam_aconf.h>
#include <stdio.h>
#include <string.h>
@@ -70,7 +67,9 @@ enum TALLY_RESET {
#endif
static struct faillog faillog;
+#ifndef MAIN
static time_t fail_time;
+#endif /* ndef MAIN */
/*---------------------------------------------------------------------*/