summaryrefslogtreecommitdiff
path: root/modules/pam_tally
diff options
context:
space:
mode:
authorChristian Göttsche <cgzones@googlemail.com>2020-10-01 10:36:41 +0200
committerDmitry V. Levin <ldv@altlinux.org>2020-10-25 08:00:00 +0000
commitb303486bf1b812dd99f48a7bbb81838d658f7e03 (patch)
treea87b5097bc6fd3824ce4c159c2244bdd3a63bd39 /modules/pam_tally
parentef9983f9d45d42f5d8adaf59592517092586ec73 (diff)
Add missing format function attributes and enable -Wmissing-format-attribute
Exported functions already have these attributes, add them to other functions. This enables compilers to find format specifier mismatches, like: foo_print("Hello %d", "world") * m4/warn_lang_flags.m4 (gl_WARN_ADD): Add -Wmissing-format-attribute. * conf/pam_conv1/Makefile.am (AM_CFLAGS): Add -I$(top_srcdir)/libpam/include. * conf/pam_conv1/pam_conv_y.y: Include <security/_pam_types.h>. (yyerror): Add printf format attribute. * modules/pam_pwhistory/opasswd.c (helper_log_err): Likewise. * modules/pam_rootok/pam_rootok.c (log_callback): Likewise. * modules/pam_tally/pam_tally.c (tally_log): Likewise. * modules/pam_tally2/pam_tally2.c (tally_log): Likewise. * modules/pam_unix/passverify.c (helper_log_err): Likewise.
Diffstat (limited to 'modules/pam_tally')
-rw-r--r--modules/pam_tally/pam_tally.c1
1 files changed, 1 insertions, 0 deletions
diff --git a/modules/pam_tally/pam_tally.c b/modules/pam_tally/pam_tally.c
index 34ae6241..6fd65009 100644
--- a/modules/pam_tally/pam_tally.c
+++ b/modules/pam_tally/pam_tally.c
@@ -94,6 +94,7 @@ struct tally_options {
#ifdef MAIN
#define pam_syslog tally_log
static void
+PAM_FORMAT((printf, 3, 4))
tally_log (const pam_handle_t *pamh UNUSED, int priority UNUSED,
const char *fmt, ...)
{