summaryrefslogtreecommitdiff
path: root/modules/pam_tally
diff options
context:
space:
mode:
authorTomas Mraz <tm@t8m.info>2005-09-21 10:00:58 +0000
committerTomas Mraz <tm@t8m.info>2005-09-21 10:00:58 +0000
commitbe09d6354efcb2571731bdffc47da86f22621ac8 (patch)
tree82117bfbaadb46495a545ba4f567dc9bddd97c33 /modules/pam_tally
parent627a0401899af257f0fb711ad54194e14a75c530 (diff)
Relevant BUGIDs:
Purpose of commit: new feature Commit summary: --------------- Moved functions from pammodutil to libpam.
Diffstat (limited to 'modules/pam_tally')
-rw-r--r--modules/pam_tally/Makefile.am5
-rw-r--r--modules/pam_tally/pam_tally.c4
2 files changed, 4 insertions, 5 deletions
diff --git a/modules/pam_tally/Makefile.am b/modules/pam_tally/Makefile.am
index a900612b..73c819c4 100644
--- a/modules/pam_tally/Makefile.am
+++ b/modules/pam_tally/Makefile.am
@@ -11,9 +11,8 @@ secureconfdir = $(SCONFIGDIR)
noinst_HEADERS = faillog.h
-AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include \
- -I$(top_srcdir)/modules/pammodutil/include/
-AM_LDFLAGS = $(top_builddir)/modules/pammodutil/libpammodutil.la \
+AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include
+AM_LDFLAGS = -no-undefined -avoid-version -module \
-L$(top_builddir)/libpam -lpam
pam_tally_la_LDFLAGS = -no-undefined -avoid-version -module
diff --git a/modules/pam_tally/pam_tally.c b/modules/pam_tally/pam_tally.c
index 579eb58f..9abe7d49 100644
--- a/modules/pam_tally/pam_tally.c
+++ b/modules/pam_tally/pam_tally.c
@@ -52,7 +52,7 @@
/* #define PAM_SM_PASSWORD */
#include <security/pam_modules.h>
-#include <security/_pam_modutil.h>
+#include <security/pam_modutil.h>
#include <security/pam_ext.h>
/*---------------------------------------------------------------------*/
@@ -238,7 +238,7 @@ pam_get_uid(pam_handle_t *pamh, uid_t *uid, const char **userp, struct tally_opt
return PAM_AUTH_ERR;
}
- if ( ! ( pw = _pammodutil_getpwnam( pamh, user ) ) ) {
+ if ( ! ( pw = pam_modutil_getpwnam( pamh, user ) ) ) {
opts->ctrl & OPT_AUDIT ?
pam_syslog(pamh, LOG_ERR, "pam_get_uid; no such user %s", user) :
pam_syslog(pamh, LOG_ERR, "pam_get_uid; no such user");