summaryrefslogtreecommitdiff
path: root/modules/pam_umask
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2007-07-06 08:23:13 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2007-07-06 08:23:13 +0000
commit4e66efa10ee4ea4dc5fcb22e48050ee7fd032187 (patch)
tree8acd12a91c51e5bbcaf53e70c619c3aeca55fd95 /modules/pam_umask
parentd6b09ee15e6d0d9fe2a5e8383b39208edcc3c843 (diff)
Relevant BUGIDs:
Purpose of commit: bugfix, release Commit summary: --------------- 2007-07-06 Thorsten Kukuk <kukuk@thkukuk.de> * release version 0.99.8.0 * configure.in: Check for audit_log_acct_message instead of audit_log_user_message. * libpam/pam_audit.c: Use audit_log_acct_message. Based on patch from Mark J Cox <mjc@redhat.com>. * libpam/Makefile.am: Bump version number of libpam. * modules/pam_umask/pam_umask.c (set_umask): mode_t is 32bit, not 64bit. * xtests/tst-pam_limits1.c: Fix printf arguments. * po/*.po: Merge po files with latest code changes.
Diffstat (limited to 'modules/pam_umask')
-rw-r--r--modules/pam_umask/pam_umask.c4
1 files changed, 2 insertions, 2 deletions
diff --git a/modules/pam_umask/pam_umask.c b/modules/pam_umask/pam_umask.c
index fdeb3c51..eb88c1ac 100644
--- a/modules/pam_umask/pam_umask.c
+++ b/modules/pam_umask/pam_umask.c
@@ -1,5 +1,5 @@
/*
- * Copyright (c) 2005, 2006 Thorsten Kukuk <kukuk@thkukuk.de>
+ * Copyright (c) 2005, 2006, 2007 Thorsten Kukuk <kukuk@thkukuk.de>
*
* Redistribution and use in source and binary forms, with or without
* modification, are permitted provided that the following conditions
@@ -181,7 +181,7 @@ set_umask (const char *value)
mask = strtoul (value, &endptr, 8) & 0777;
if (((mask == 0) && (value_orig == endptr)) ||
- ((mask == ULONG_MAX) && (errno == ERANGE)))
+ ((mask == UINT_MAX) && (errno == ERANGE)))
return;
umask (mask);
return;