summaryrefslogtreecommitdiff
path: root/modules/pam_unix/Makefile.am
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-09-20 13:46:03 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-09-20 13:46:03 +0000
commit8440c76a17e011bef9431c2ac93fc708d7c62e4c (patch)
treee3c4e3455b67e3418e60e9b8d06bd13b82939423 /modules/pam_unix/Makefile.am
parent3cfe9272773f1d6356534b1c30ebaea0a896db93 (diff)
Relevant BUGIDs:
Purpose of commit: new feature/bugfix Commit summary: --------------- 2006-09-20 Thorsten Kukuk <kukuk@thkukuk.de> * doc/adg/Makefile.am: Add manual pages as dependency. * doc/mwg/Makefile.am: Likewise. * doc/sag/Makefile.am: Likewise. * doc/sag/Linux-PAM_SAG.xml: Include pam_unix.xml. * doc/sag/pam_unix.xml: New. * modules/pam_unix/Makefile.am: Generate pam_unix.8 manual page. * modules/pam_unix/README.xml: New. * modules/pam_unix/pam_unix.8.xml: New. * modules/pam_unix/README: Regenerate from XML. * modules/pam_unix/pam_unix.8: Generated from XML.
Diffstat (limited to 'modules/pam_unix/Makefile.am')
-rw-r--r--modules/pam_unix/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/modules/pam_unix/Makefile.am b/modules/pam_unix/Makefile.am
index 36dca982..5f60d98b 100644
--- a/modules/pam_unix/Makefile.am
+++ b/modules/pam_unix/Makefile.am
@@ -5,11 +5,12 @@
CLEANFILES = *~
EXTRA_DIST = README md5.c md5_crypt.c lckpwdf.-c $(MANS) CHANGELOG \
- tst-pam_unix
+ tst-pam_unix $(XMLS)
-TESTS = tst-pam_unix
+man_MANS = pam_unix.8 unix_chkpwd.8
+XMLS = README.xml pam_unix.8.xml
-man_MANS = unix_chkpwd.8
+TESTS = tst-pam_unix
securelibdir = $(SECUREDIR)
secureconfdir = $(SCONFIGDIR)
@@ -50,3 +51,10 @@ bigcrypt_CFLAGS = $(AM_CFLAGS)
unix_chkpwd_SOURCES = unix_chkpwd.c md5_good.c md5_broken.c bigcrypt.c
unix_chkpwd_CFLAGS = $(AM_CFLAGS) @PIE_CFLAGS@
unix_chkpwd_LDFLAGS = @PIE_LDFLAGS@
+
+if ENABLE_REGENERATE_MAN
+noinst_DATA = README
+README: pam_unix.8.xml
+-include $(top_srcdir)/Make.xml.rules
+endif
+