summaryrefslogtreecommitdiff
path: root/modules/pam_unix/bigcrypt.h
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-06-15 21:09:49 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-06-15 21:09:49 +0000
commit3387d7584dc78587bb621b0bc4d4e80df576399e (patch)
treee9062f1e9d61115d15a8b5fc97d35567023760c2 /modules/pam_unix/bigcrypt.h
parent3ab490d6a2dd0b0466c334595f7c3460988e5ffd (diff)
Relevant BUGIDs:
Purpose of commit: cleanup Commit summary: --------------- Put bigcrypt prototype in own header instead of an external declaration in every single file calling bigcrypt: 2006-06-15 Thorsten Kukuk <kukuk@thkukuk.de> * modules/pam_unix/bigcrypt.h: New. * modules/pam_unix/Makefile.am: Add bigcrypt.h. * modules/pam_unix/bigcrypt.c: Include bigcrypt.h. * modules/pam_unix/support.c: Include bigcrypt.h, remove own prototype. * modules/pam_unix/bigcrypt_main.c: Include bigcrypt.h, remove own prototype. * modules/pam_unix/pam_unix_passwd.c: Include bigcrypt.h, remove own prototype.
Diffstat (limited to 'modules/pam_unix/bigcrypt.h')
-rw-r--r--modules/pam_unix/bigcrypt.h1
1 files changed, 1 insertions, 0 deletions
diff --git a/modules/pam_unix/bigcrypt.h b/modules/pam_unix/bigcrypt.h
new file mode 100644
index 00000000..a66a96e6
--- /dev/null
+++ b/modules/pam_unix/bigcrypt.h
@@ -0,0 +1 @@
+extern char *bigcrypt(const char *key, const char *salt);