summaryrefslogtreecommitdiff
path: root/modules/pam_unix/support.h
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2008-12-01 12:40:40 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2008-12-01 12:40:40 +0000
commit090693e116fc6ea0dfb649e11a01af08e19b33d9 (patch)
tree1d3cde1416515bc7136e604d58e96e90caa510be /modules/pam_unix/support.h
parent1395ff30321ce605ab2ca79b1301cd93f51a5ca1 (diff)
Relevant BUGIDs:
Purpose of commit: new feature Commit summary: --------------- 2008-12-01 Thorsten Kukuk <kukuk@thkukuk.de> * modules/pam_unix/pam_unix.8.xml: Document blowfish option. * configure.in: Check for crypt_gensalt_rn. * modules/pam_unix/pam_unix_passwd.c: Pass pamh to create_password_hash function. * modules/pam_unix/passverify.c (create_password_hash): Add blowfish support. * modules/pam_unix/passverify.h: Adjust create_password_hash prototype. * modules/pam_unix/support.c: Add support for blowfish option. * modules/pam_unix/support.h: Add defines for blowfish option. Patch from Diego Flameeyes Pettenò <flameeyes@gmail.com>
Diffstat (limited to 'modules/pam_unix/support.h')
-rw-r--r--modules/pam_unix/support.h4
1 files changed, 3 insertions, 1 deletions
diff --git a/modules/pam_unix/support.h b/modules/pam_unix/support.h
index a33dadaa..86575ff0 100644
--- a/modules/pam_unix/support.h
+++ b/modules/pam_unix/support.h
@@ -88,8 +88,9 @@ typedef struct {
#define UNIX_SHA512_PASS 24 /* new password hashes will use SHA512 */
#define UNIX_ALGO_ROUNDS 25 /* optional number of rounds for new
password hash algorithms */
+#define UNIX_BLOWFISH_PASS 26 /* new password hashes will use blowfish */
/* -------------- */
-#define UNIX_CTRLS_ 26 /* number of ctrl arguments defined */
+#define UNIX_CTRLS_ 27 /* number of ctrl arguments defined */
static const UNIX_Ctrls unix_args[UNIX_CTRLS_] =
{
@@ -122,6 +123,7 @@ static const UNIX_Ctrls unix_args[UNIX_CTRLS_] =
/* UNIX_SHA256_PASS */ {"sha256", _ALL_ON_^(040420000), 020000000},
/* UNIX_SHA512_PASS */ {"sha512", _ALL_ON_^(020420000), 040000000},
/* UNIX_ALGO_ROUNDS */ {"rounds=", _ALL_ON_, 0100000000},
+/* UNIX_BLOWFISH_PASS */ {"blowfish", _ALL_ON_^(060420000),0200000000},
};
#define UNIX_DEFAULTS (unix_args[UNIX__NONULL].flag)