summaryrefslogtreecommitdiff
path: root/modules/pam_unix
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2003-07-13 18:41:04 +0000
committerSteve Langasek <vorlon@debian.org>2003-07-13 18:41:04 +0000
commit2f36c829822a4b016ba075575c720ad9cb3c6463 (patch)
tree51b4a20becbd7b9d92b6bc0d73565a438525265d /modules/pam_unix
parenteaffa5288f918a542c5322b79975793efc1b3a10 (diff)
Relevant BUGIDs: 643357
Purpose of commit: bugfix Commit summary: --------------- Patch from Sam Hartman to fix handling of module linking on Linux: modules should be linked against libpam if they call any functions from the library, since not all platforms will correctly resolve symbol references otherwise. Also, make sure we use gcc, not ld, when linking, since there's additional linker glue that gcc will pull in for us.
Diffstat (limited to 'modules/pam_unix')
-rw-r--r--modules/pam_unix/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/pam_unix/Makefile b/modules/pam_unix/Makefile
index 0cab34bc..61c4beaa 100644
--- a/modules/pam_unix/Makefile
+++ b/modules/pam_unix/Makefile
@@ -109,7 +109,7 @@ ifdef DYNAMIC
$(LIBOBJD): $(LIBSRC)
$(LIBSHARED): $(LIBOBJD)
- $(LD_D) -o $@ $(LIBOBJD) $(PLUS) $(CRACKLIB) $(LDLIBS) $(LIBNSL) $(LIBCRYPT)
+ $(LD_D) -o $@ $(LIBOBJD) $(PLUS) $(CRACKLIB) $(LDLIBS) $(LIBNSL) $(LIBCRYPT) $(NEED_LINK_LIB_C) -L../../libpam -lpam
endif
ifdef STATIC