summaryrefslogtreecommitdiff
path: root/modules/pam_xauth
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2007-10-01 09:41:32 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2007-10-01 09:41:32 +0000
commit417cb2fbd8bd7ca905c5611588654516c58bced1 (patch)
tree603035e7403a52d403b9cf4e365b080c469d989f /modules/pam_xauth
parent1435f0a4045b3af4f1390aa8b9054b8ac9a0a0b4 (diff)
Relevant BUGIDs:
Purpose of commit: bugfix Commit summary: --------------- 2007-10-01 Thorsten Kukuk <kukuk@thkukuk.de> * xtests/tst-pam_group1.c: New test case for user compare in pam_group. * xtests/tst-pam_group1.sh: Script to run test case. * xtests/tst-pam_group1.pamd: Config for test case. * xtests/Makefile.am: Add tst-pam_group1 test case. * xtests/run-xtests.sh: Save/restore group.conf. * xtests/group.conf: New. * modules/pam_xauth/pam_xauth.c (pam_sm_open_session): Don't free arguments used for putenv(). * doc/man/pam_putenv.3.xml: Document that application has to free the memory.
Diffstat (limited to 'modules/pam_xauth')
-rw-r--r--modules/pam_xauth/pam_xauth.c1
1 files changed, 1 insertions, 0 deletions
diff --git a/modules/pam_xauth/pam_xauth.c b/modules/pam_xauth/pam_xauth.c
index 153210f1..1135d4b7 100644
--- a/modules/pam_xauth/pam_xauth.c
+++ b/modules/pam_xauth/pam_xauth.c
@@ -578,6 +578,7 @@ pam_sm_open_session (pam_handle_t *pamh, int flags UNUSED,
"can't set environment variable '%s'",
xauthority);
putenv (xauthority); /* The environment owns this string now. */
+ xauthority = NULL; /* Don't free environment variables. */
/* set $DISPLAY in pam handle to make su - work */
{