summaryrefslogtreecommitdiff
path: root/modules
diff options
context:
space:
mode:
authorTomas Mraz <tm@t8m.info>2008-02-29 15:22:03 +0000
committerTomas Mraz <tm@t8m.info>2008-02-29 15:22:03 +0000
commit9484d6c4621ca3b0258005e49959d77e9e127ae0 (patch)
treecc024aa3d41b799c2a4617be6731e15ab4f70be6 /modules
parent8e0e3534a2ab00803759b98a3f5b3a228434e9ef (diff)
Relevant BUGIDs:
Purpose of commit: cleanup Commit summary: --------------- 2008-02-26 Tomas Mraz <t8m@centrum.cz> * modules/pam_unix/Makefile.am: Do not link to cracklib. * modules/pam_unix/pam_unix_passwd.c(_pam_unix_approve_pass): Do not call FascistCheck() from cracklib.
Diffstat (limited to 'modules')
-rw-r--r--modules/pam_unix/Makefile.am5
-rw-r--r--modules/pam_unix/pam_unix_passwd.c12
2 files changed, 1 insertions, 16 deletions
diff --git a/modules/pam_unix/Makefile.am b/modules/pam_unix/Makefile.am
index 4d2c58b8..61a3b0ce 100644
--- a/modules/pam_unix/Makefile.am
+++ b/modules/pam_unix/Makefile.am
@@ -22,15 +22,12 @@ AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include \
if HAVE_LIBSELINUX
AM_CFLAGS += -D"WITH_SELINUX"
endif
-if HAVE_LIBCRACK
- AM_CFLAGS += -D"USE_CRACKLIB"
-endif
pam_unix_la_LDFLAGS = -no-undefined -avoid-version -module
if HAVE_VERSIONING
pam_unix_la_LDFLAGS += -Wl,--version-script=$(srcdir)/../modules.map
endif
-pam_unix_la_LIBADD = @LIBCRACK@ @LIBNSL@ -L$(top_builddir)/libpam -lpam \
+pam_unix_la_LIBADD = @LIBNSL@ -L$(top_builddir)/libpam -lpam \
@LIBCRYPT@ @LIBSELINUX@
securelib_LTLIBRARIES = pam_unix.la
diff --git a/modules/pam_unix/pam_unix_passwd.c b/modules/pam_unix/pam_unix_passwd.c
index 432f687f..d221220f 100644
--- a/modules/pam_unix/pam_unix_passwd.c
+++ b/modules/pam_unix/pam_unix_passwd.c
@@ -67,10 +67,6 @@ static int selinux_enabled=-1;
#define SELINUX_ENABLED (selinux_enabled!=-1 ? selinux_enabled : (selinux_enabled=is_selinux_enabled()>0))
#endif
-#ifdef USE_CRACKLIB
-#include <crack.h>
-#endif
-
#include <security/_pam_macros.h>
/* indicate the following groups are defined */
@@ -106,9 +102,6 @@ extern int getrpcport(const char *host, unsigned long prognum,
#define _UNIX_NEW_AUTHTOK "-UN*X-NEW-PASS"
#define MAX_PASSWD_TRIES 3
-#ifndef CRACKLIB_DICTS
-#define CRACKLIB_DICTS NULL
-#endif
static char *getNISserver(pam_handle_t *pamh)
{
@@ -469,14 +462,9 @@ static int _pam_unix_approve_pass(pam_handle_t * pamh
}
}
if (off(UNIX__IAMROOT, ctrl)) {
-#ifdef USE_CRACKLIB
- remark = FascistCheck (pass_new, CRACKLIB_DICTS);
- D(("called cracklib [%s]", remark));
-#else
if (strlen(pass_new) < 6)
remark = _("You must choose a longer password");
D(("length check [%s]", remark));
-#endif
if (on(UNIX_REMEMBER_PASSWD, ctrl)) {
if ((retval = check_old_password(user, pass_new)) == PAM_AUTHTOK_ERR)
remark = _("Password has been already used. Choose another.");