summaryrefslogtreecommitdiff
path: root/modules
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-08-05 08:03:11 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-08-05 08:03:11 +0000
commit72bcf614b2a5e5f281ca4372fa7dfccf1e6a3c43 (patch)
treeee1821fdda266c77a0f4ae403fe4358e7c45a47d /modules
parentea9255e046169e5d5b19370c9ae6292be5aacde0 (diff)
Relevant BUGIDs:
Purpose of commit: new feature Commit summary: --------------- Add xtests to allow checks for PAM functions only doable in installed system. 2006-08-05 Thorsten Kukuk <kukuk@thkukuk.de> * configure.in: Generate xtests/Makefile. * Makefile.am (SUBDIRS): Add xtests. * README: Document make check and make xtests. * xtests/Makefile.am: New. * xtests/tst-pam_dispatch1.pamd: New. * xtests/tst-pam_dispatch2.pamd: New. * xtests/tst-pam_dispatch3.pamd: New. * xtests/tst-pam_dispatch1.c: New. * xtests/tst-pam_dispatch2.c: New. * xtests/tst-pam_dispatch3.c: New.
Diffstat (limited to 'modules')
-rw-r--r--modules/pam_succeed_if/README18
-rw-r--r--modules/pam_succeed_if/pam_succeed_if.821
2 files changed, 34 insertions, 5 deletions
diff --git a/modules/pam_succeed_if/README b/modules/pam_succeed_if/README
index c8d2ceff..4516a9d1 100644
--- a/modules/pam_succeed_if/README
+++ b/modules/pam_succeed_if/README
@@ -38,7 +38,7 @@ quiet_success
Conditions are three words: a field, a test, and a value to test for.
-Available fields are user, uid, gid, shell and home:
+Available fields are user, uid, gid, shell, home and service:
field < number
@@ -80,6 +80,14 @@ field !~ glob
Field does not match the given glob.
+field in item:item:...
+
+ Field is contained in the list of items separated by colons.
+
+field notin item:item:...
+
+ Field is not contained in the list of items separated by colons.
+
user ingroup group
User is in given group.
@@ -88,6 +96,14 @@ user notingroup group
User is not in given group.
+user innetgr netgroup
+
+ (user,host) is in given netgroup.
+
+user notinnetgr group
+
+ (user,host) is not in given netgroup.
+
EXAMPLES
To emulate the behaviour of pam_wheel, except there is no fallback to group 0:
diff --git a/modules/pam_succeed_if/pam_succeed_if.8 b/modules/pam_succeed_if/pam_succeed_if.8
index 4603eba1..c94c5f43 100644
--- a/modules/pam_succeed_if/pam_succeed_if.8
+++ b/modules/pam_succeed_if/pam_succeed_if.8
@@ -1,11 +1,11 @@
.\" Title: pam_succeed_if
.\" Author:
.\" Generator: DocBook XSL Stylesheets v1.70.1 <http://docbook.sf.net/>
-.\" Date: 06/22/2006
+.\" Date: 08/05/2006
.\" Manual: Linux\-PAM
.\" Source: Linux\-PAM
.\"
-.TH "PAM_SUCCEED_IF" "8" "06/22/2006" "Linux\-PAM" "Linux\-PAM"
+.TH "PAM_SUCCEED_IF" "8" "08/05/2006" "Linux\-PAM" "Linux\-PAM"
.\" disable hyphenation
.nh
.\" disable justification (adjust text to left margin only)
@@ -47,9 +47,10 @@ Available fields are
\fIuser\fR,
\fIuid\fR,
\fIgid\fR,
-\fIshell\fR
+\fIshell\fR,
+\fIhome\fR
and
-\fIhome\fR:
+\fIservice\fR:
.TP 3n
\fBfield < number\fR
Field has a value numerically less than number.
@@ -81,11 +82,23 @@ Field matches the given glob.
\fBfield !~ glob\fR
Field does not match the given glob.
.TP 3n
+\fBfield in item:item:...\fR
+Field is contained in the list of items separated by colons.
+.TP 3n
+\fBfield notin item:item:...\fR
+Field is not contained in the list of items separated by colons.
+.TP 3n
\fBuser ingroup group\fR
User is in given group.
.TP 3n
\fBuser notingroup group\fR
User is not in given group.
+.TP 3n
+\fBuser innetgr netgroup\fR
+(user,host) is in given netgroup.
+.TP 3n
+\fBuser notinnetgr group\fR
+(user,host) is not in given netgroup.
.SH "MODULE SERVICES PROVIDED"
.PP
The