summaryrefslogtreecommitdiff
path: root/tests/tst-dlopen.c
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2007-11-06 14:46:57 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2007-11-06 14:46:57 +0000
commita38a8eae25ee1d7adb5a5eafcf1c41e94974ed90 (patch)
treef4e4ba1dd2aa06bfdba08f88cdd0fd05cac8b5b3 /tests/tst-dlopen.c
parent675a1e8f0b0227cae757fdfa197fff944730b516 (diff)
Relevant BUGIDs: 1822779
Purpose of commit: bugfix Commit summary: --------------- 2007-11-06 Thorsten Kukuk <kukuk@thkukuk.de> * libpam/pam_static_modules.h: Fix name of pam_namespace variable. 2007-10-30 Peter Breitenlohner <peb@mppmu.mpg.de> * tests/tst-dlopen.c: Return 77 in case of static modules, such that all modules/pam_*/tst-pam_* tests yield SKIP instead of FAIL. * libpam/Makefile.am (libpam_la_LIBADD): Use "$(shell ls ...)" instead of "`ls ...`", to allow for static modules. * libpam/pam_static_modules.h: Make pam_keyinit module depend on HAVE_KEY_MANAGEMENT; correct name of pam_faildelay pam_module struct. * modules/pam_faildelay/pam_faildelay.c: Correct name of pam_module struct.
Diffstat (limited to 'tests/tst-dlopen.c')
-rw-r--r--tests/tst-dlopen.c4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/tst-dlopen.c b/tests/tst-dlopen.c
index 272d58bc..e4770eea 100644
--- a/tests/tst-dlopen.c
+++ b/tests/tst-dlopen.c
@@ -19,6 +19,9 @@
/* Simple program to see if dlopen() would succeed. */
int main(int argc, char **argv)
{
+#ifdef PAM_STATIC
+ return 77;
+#else
int i;
struct stat st;
char buf[PATH_MAX];
@@ -40,5 +43,6 @@ int main(int argc, char **argv)
}
}
return 0;
+#endif
}