summaryrefslogtreecommitdiff
path: root/xtests/Makefile.am
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-08-06 11:38:43 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-08-06 11:38:43 +0000
commit9fe629581bf126af81233706e71bec60decee79c (patch)
tree24358d9de5cd0f6f399cef9761dcbd5af03a9b9e /xtests/Makefile.am
parentea68558c25723480e609918b8ce11b3a8ac10b93 (diff)
Relevant BUGIDs:
Purpose of commit: bugfix Commit summary: --------------- 2006-08-06 Thorsten Kukuk <kukuk@thkukuk.de> * modules/pam_umask/pam_umask.c (setup_limits_from_gecos): Add error handling. * modules/pam_umask/pam_umask.8.xml: Document silent option. * xtests/Makefile.am: Fix includes for bootstrapping. Reported by Greg Schafer <gschafer@zip.com.au>.
Diffstat (limited to 'xtests/Makefile.am')
-rw-r--r--xtests/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/xtests/Makefile.am b/xtests/Makefile.am
index 622e3e59..549ef8c9 100644
--- a/xtests/Makefile.am
+++ b/xtests/Makefile.am
@@ -2,8 +2,10 @@
# Copyright (c) 2006 Thorsten Kukuk <kukuk@suse.de>
#
-AM_CFLAGS = -DLIBPAM_COMPILE -I$(top_srcdir)/libpam/include
-AM_LDFLAGS = -L$(top_builddir)/libpam -lpam
+AM_CFLAGS = -DLIBPAM_COMPILE -I$(top_srcdir)/libpam/include \
+ -I$(top_srcdir)/libpamc/include -I$(top_srcdir)/libpam_misc/include
+AM_LDFLAGS = -L$(top_builddir)/libpam -lpam \
+ -L$(top_builddir)/libpam_misc -lpam_misc
CLEANFILES = *~
@@ -14,10 +16,6 @@ XTESTS = tst-pam_dispatch1 tst-pam_dispatch2 tst-pam_dispatch3
noinst_PROGRAMS = $(XTESTS)
-tst_pam_dispatch1_LDADD = -L$(top_builddir)/libpam -lpam -ldl -L$(top_builddir)/libpam_misc -lpam_misc
-tst_pam_dispatch2_LDADD = -L$(top_builddir)/libpam -lpam -ldl -L$(top_builddir)/libpam_misc -lpam_misc
-tst_pam_dispatch3_LDADD = -L$(top_builddir)/libpam -lpam -ldl -L$(top_builddir)/libpam_misc -lpam_misc
-
xtests: $(XTESTS)
@failed=0; pass=0; all=0; \
for testname in $(XTESTS) ; do \