summaryrefslogtreecommitdiff
path: root/xtests/run-xtests.sh
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2009-03-09 13:07:34 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2009-03-09 13:07:34 +0000
commit72855d240704c34326c9ae2db56e18f926218b3b (patch)
tree31984c627dd13cdd52597a3a036d0f2f07d73bd3 /xtests/run-xtests.sh
parentc773c1786718c76155074331c7da60e934786da3 (diff)
Relevant BUGIDs:
Purpose of commit: release Commit summary: --------------- 2009-03-09 Thorsten Kukuk <kukuk@thkukuk.de> * release version 1.0.91 * libpam/Makefile.am (libpam_la_LDFLAGS): Bump version number. * xtests/Makefile.am: Add tst-pam_unix4.pamd, tst-pam_unix4.sh and time.conf.
Diffstat (limited to 'xtests/run-xtests.sh')
-rwxr-xr-xxtests/run-xtests.sh3
1 files changed, 2 insertions, 1 deletions
diff --git a/xtests/run-xtests.sh b/xtests/run-xtests.sh
index 73433630..3a890578 100755
--- a/xtests/run-xtests.sh
+++ b/xtests/run-xtests.sh
@@ -27,7 +27,8 @@ for testname in $XTESTS ; do
for cfg in "${SRCDIR}"/$testname*.pamd ; do
install -m 644 $cfg /etc/pam.d/$(basename $cfg .pamd)
done
- if test -x "${SRCDIR}"/$testname.sh ; then
+ if test -f "${SRCDIR}"/$testname.sh ; then
+ test -x "${SRCDIR}"/$testname.sh || chmod 755 "${SRCDIR}"/$testname.sh
"${SRCDIR}"/$testname.sh > /dev/null
else
./$testname > /dev/null