summaryrefslogtreecommitdiff
path: root/xtests/run-xtests.sh
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2008-11-24 14:13:04 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2008-11-24 14:13:04 +0000
commit6aac14af273cb2b3dd6008b23e0576306d514e7d (patch)
treeaf18f2682676cfc5af40e37445df41172d399848 /xtests/run-xtests.sh
parentb66f2f941f5dd41710b0e3f3251d5d664602911f (diff)
Relevant BUGIDs: debian #326407
Purpose of commit: new testcase Commit summary: --------------- User entries with "|" don't work as expected. 2008-11-24 Thorsten Kukuk <kukuk@thkukuk.de> * xtests/Makefile.am: Add pam_time1 tests. * xtests/tst-pam_time1.c: New test case. * xtests/tst-pam_time1.pamd: New. * xtests/time.conf: New. * xtests/run-xtests.sh: Copy time.conf.
Diffstat (limited to 'xtests/run-xtests.sh')
-rwxr-xr-xxtests/run-xtests.sh11
1 files changed, 5 insertions, 6 deletions
diff --git a/xtests/run-xtests.sh b/xtests/run-xtests.sh
index b06685da..73433630 100755
--- a/xtests/run-xtests.sh
+++ b/xtests/run-xtests.sh
@@ -17,12 +17,10 @@ skiped=0
all=0
mkdir -p /etc/security
-cp /etc/security/access.conf /etc/security/access.conf-pam-xtests
-install -m 644 "${SRCDIR}"/access.conf /etc/security/access.conf
-cp /etc/security/group.conf /etc/security/group.conf-pam-xtests
-install -m 644 "${SRCDIR}"/group.conf /etc/security/group.conf
-cp /etc/security/limits.conf /etc/security/limits.conf-pam-xtests
-install -m 644 "${SRCDIR}"/limits.conf /etc/security/limits.conf
+for config in access.conf group.conf time.conf limits.conf ; do
+ cp /etc/security/$config /etc/security/$config-pam-xtests
+ install -m 644 "${SRCDIR}"/$config /etc/security/$config
+done
mv /etc/security/opasswd /etc/security/opasswd-pam-xtests
for testname in $XTESTS ; do
@@ -50,6 +48,7 @@ for testname in $XTESTS ; do
done
mv /etc/security/access.conf-pam-xtests /etc/security/access.conf
mv /etc/security/group.conf-pam-xtests /etc/security/group.conf
+mv /etc/security/time.conf-pam-xtests /etc/security/time.conf
mv /etc/security/limits.conf-pam-xtests /etc/security/limits.conf
mv /etc/security/opasswd-pam-xtests /etc/security/opasswd
if test "$failed" -ne 0; then