summaryrefslogtreecommitdiff
path: root/xtests/run-xtests.sh
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2007-01-31 19:19:44 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2007-01-31 19:19:44 +0000
commitb12b648d8357e5baa5c607ca6703380b1e77b013 (patch)
tree2748fe8509c02c3567543bc665bb2e3edf72cdbf /xtests/run-xtests.sh
parent7cbfa335c57d068d59508c844f3957165cccfb9b (diff)
Relevant BUGIDs:
Purpose of commit: new feature Commit summary: --------------- 2007-01-31 Thorsten Kukuk <kukuk@thkukuk.de> * xtests/Makefile.am: Add new pam_unix.so tests * xtests/run-xtests.sh: Prefer shell scripts (wrapper) over binaries. * xtests/tst-pam_cracklib1.c: Fix typo. * xtests/tst-pam_unix1.c: New, for sucurity fix. * xtests/tst-pam_unix1.pamd: New. * xtests/tst-pam_unix1.sh: New. * xtests/tst-pam_unix2.c: New, for crypt checks. * xtests/tst-pam_unix2.pamd: New. * xtests/tst-pam_unix2.sh: New. * xtests/tst-pam_unix3.c: New, for bigcrypt checks. * xtests/tst-pam_unix3.pamd: New. * xtests/tst-pam_unix3.sh: New.
Diffstat (limited to 'xtests/run-xtests.sh')
-rwxr-xr-xxtests/run-xtests.sh9
1 files changed, 6 insertions, 3 deletions
diff --git a/xtests/run-xtests.sh b/xtests/run-xtests.sh
index 9c8c3571..ce49fcda 100755
--- a/xtests/run-xtests.sh
+++ b/xtests/run-xtests.sh
@@ -5,8 +5,7 @@ if test `id -u` -ne 0 ; then
exit 1
fi
-XTESTS="tst-pam_dispatch1 tst-pam_dispatch2 tst-pam_dispatch3 \
- tst-pam_dispatch4 tst-pam_cracklib1"
+XTESTS="$@"
failed=0
pass=0
@@ -14,7 +13,11 @@ all=0
for testname in $XTESTS ; do
install -m 644 $testname.pamd /etc/pam.d/$testname
- ./$testname > /dev/null
+ if test -x ./$testname.sh ; then
+ ./$testname.sh > /dev/null
+ else
+ ./$testname > /dev/null
+ fi
if test $? -ne 0 ; then
echo "FAIL: $testname"
failed=`expr $failed + 1`