summaryrefslogtreecommitdiff
path: root/xtests/tst-pam_access1.sh
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2007-06-25 11:09:32 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2007-06-25 11:09:32 +0000
commitdd80f758c4772b8bebb2fc3335bf3457ab1eb7ca (patch)
tree0fe639587103fc1b4a961bddff260ae508f5d73c /xtests/tst-pam_access1.sh
parentcc4a814d318d7926bb73dec21c99f46f6ef31d3a (diff)
Relevant BUGIDs:
Purpose of commit: bugfix Commit summary: --------------- 2007-06-25 Thorsten Kukuk <kukuk@thkukuk.de> * modules/pam_access/pam_access.c (list_match): Use saveptr of strtok_r result for recursive calls. * xtests/Makefile.am: Add new pam_access test cases. * xtests/pam_access1.c: New test case. * xtests/pam_access2.c: Likewise. * xtests/pam_access3.c: Likewise. * xtests/pam_access4.c: Likewise. * xtests/pam_access1.sh: Wrapper to create user accounts. * xtests/pam_access2.sh: Likewise. * xtests/pam_access3.sh: Likewise. * xtests/pam_access4.sh: Likewise. * xtests/pam_access1.pamd: PAM config file for pam_access tests. * xtests/pam_access2.pamd: Likewise. * xtests/pam_access3.pamd: Likewise. * xtests/pam_access4.pamd: Likewise. * xtests/access.conf: Config file for pam_access tests. * xtests/run-tests.sh: Install access.conf into system.
Diffstat (limited to 'xtests/tst-pam_access1.sh')
-rwxr-xr-xxtests/tst-pam_access1.sh9
1 files changed, 9 insertions, 0 deletions
diff --git a/xtests/tst-pam_access1.sh b/xtests/tst-pam_access1.sh
new file mode 100755
index 00000000..48d8cb3e
--- /dev/null
+++ b/xtests/tst-pam_access1.sh
@@ -0,0 +1,9 @@
+#!/bin/bash
+
+/usr/sbin/groupadd -p '!!' tstpamaccess
+/usr/sbin/useradd -G tstpamaccess -p '!!' tstpamaccess
+./tst-pam_access1
+RET=$?
+/usr/sbin/userdel -r tstpamaccess 2> /dev/null
+/usr/sbin/groupdel tstpamaccess 2> /dev/null
+exit $RET