summaryrefslogtreecommitdiff
path: root/xtests/tst-pam_cracklib1.c
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-08-30 08:45:30 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-08-30 08:45:30 +0000
commit424578c5c4a5edbd79142c9348f4eda689530651 (patch)
tree6ef01329b2a0fb48e171b382f777eb1347494f86 /xtests/tst-pam_cracklib1.c
parentd668e9e5eed079686000f0979391f3691a54408a (diff)
Relevant BUGIDs:
Purpose of commit: cleanup/bugfix Commit summary: --------------- 2006-08-30 Thorsten Kukuk <kukuk@thkukuk.de> * xtests/Makefile.am: Move shell code to execute tests from here ... * xtests/run-xtests.sh: ... to here. * xtests/*.c: Include config.h. * tests/*.c: Likewise.
Diffstat (limited to 'xtests/tst-pam_cracklib1.c')
-rw-r--r--xtests/tst-pam_cracklib1.c40
1 files changed, 38 insertions, 2 deletions
diff --git a/xtests/tst-pam_cracklib1.c b/xtests/tst-pam_cracklib1.c
index d0b92d77..6c0ec321 100644
--- a/xtests/tst-pam_cracklib1.c
+++ b/xtests/tst-pam_cracklib1.c
@@ -1,3 +1,39 @@
+/*
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, and the entire permission notice in its entirety,
+ * including the disclaimer of warranties.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ * 3. The name of the author may not be used to endorse or promote
+ * products derived from this software without specific prior
+ * written permission.
+ *
+ * ALTERNATIVELY, this product may be distributed under the terms of
+ * the GNU Public License, in which case the provisions of the GPL are
+ * required INSTEAD OF the above restrictions. (This clause is
+ * necessary due to a potential bad interaction between the GPL and
+ * the restrictions contained in a BSD-style copyright.)
+ *
+ * THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESS OR IMPLIED
+ * WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+ * OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+ * DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT,
+ * INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+ * (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+ * SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+ * STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
+ * OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
+
+#ifdef HAVE_CONFIG_H
+#include <config.h>
+#endif
#include <stdio.h>
#include <string.h>
@@ -6,8 +42,8 @@
/* A conversation function which uses an internally-stored value for
the responses. */
static int
-fake_conv (int num_msg, const struct pam_message **msgm,
- struct pam_response **response, void *appdata_ptr)
+fake_conv (int num_msg, const struct pam_message **msgm UNUSED,
+ struct pam_response **response, void *appdata_ptr UNUSED)
{
static int calls = 0;
struct pam_response *reply;