summaryrefslogtreecommitdiff
path: root/xtests/tst-pam_cracklib1.c
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2008-12-03 14:16:33 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2008-12-03 14:16:33 +0000
commitf326d04ccd16631d57134487e56bb73074f0dd0e (patch)
treebe55fce45e805e98057c1920a5f0ebaffa2b6650 /xtests/tst-pam_cracklib1.c
parentde63f0160c57494553e400aca215ffe316e946b7 (diff)
Relevant BUGIDs:
Purpose of commit: new feature Commit summary: --------------- 2008-12-03 Thorsten Kukuk <kukuk@suse.de> * doc/man/Makefile.am: Add pam_get_authtok.3.xml. * doc/man/pam_get_authtok.3.xml: New. * libpam/Makefile.am: Add pam_get_authtok.c. * libpam/libpam.map: Export pam_get_authtok. * libpam/pam_get_authtok.c: New. * libpam/pam_private.h: Add mod_argc and mod_argv to pam_handle. * libpam_include/security/pam_ext.h: Add pam_get_authtok prototype. * modules/pam_cracklib/pam_cracklib.c: Use pam_get_authtok. * modules/pam_pwhistory/pam_pwhistory.c: Likewise. * po/POTFILES.in: Add libpam/pam_get_authtok.c. * xtests/tst-pam_cracklib1.c: Adjust error codes. * modules/pam_timestamp/Makefile.am: Remove hmactest.c from EXTRA_DIST. * po/*.po: Regenerated.
Diffstat (limited to 'xtests/tst-pam_cracklib1.c')
-rw-r--r--xtests/tst-pam_cracklib1.c4
1 files changed, 2 insertions, 2 deletions
diff --git a/xtests/tst-pam_cracklib1.c b/xtests/tst-pam_cracklib1.c
index b0e52051..1a219c83 100644
--- a/xtests/tst-pam_cracklib1.c
+++ b/xtests/tst-pam_cracklib1.c
@@ -107,7 +107,7 @@ main(int argc, char *argv[])
/* Try one, first input is correct, second is NULL */
retval = pam_chauthtok (pamh, 0);
- if (retval != PAM_AUTHTOK_RECOVERY_ERR)
+ if (retval != PAM_AUTHTOK_ERR)
{
if (debug)
fprintf (stderr, "cracklib1-1: pam_chauthtok returned %d\n", retval);
@@ -116,7 +116,7 @@ main(int argc, char *argv[])
/* Try two, second input is NULL */
retval = pam_chauthtok (pamh, 0);
- if (retval != PAM_AUTHTOK_RECOVERY_ERR)
+ if (retval != PAM_AUTHTOK_ERR)
{
if (debug)
fprintf (stderr, "cracklib1-2: pam_chauthtok returned %d\n", retval);