summaryrefslogtreecommitdiff
path: root/xtests/tst-pam_limits1.c
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2007-07-06 08:23:13 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2007-07-06 08:23:13 +0000
commit4e66efa10ee4ea4dc5fcb22e48050ee7fd032187 (patch)
tree8acd12a91c51e5bbcaf53e70c619c3aeca55fd95 /xtests/tst-pam_limits1.c
parentd6b09ee15e6d0d9fe2a5e8383b39208edcc3c843 (diff)
Relevant BUGIDs:
Purpose of commit: bugfix, release Commit summary: --------------- 2007-07-06 Thorsten Kukuk <kukuk@thkukuk.de> * release version 0.99.8.0 * configure.in: Check for audit_log_acct_message instead of audit_log_user_message. * libpam/pam_audit.c: Use audit_log_acct_message. Based on patch from Mark J Cox <mjc@redhat.com>. * libpam/Makefile.am: Bump version number of libpam. * modules/pam_umask/pam_umask.c (set_umask): mode_t is 32bit, not 64bit. * xtests/tst-pam_limits1.c: Fix printf arguments. * po/*.po: Merge po files with latest code changes.
Diffstat (limited to 'xtests/tst-pam_limits1.c')
-rw-r--r--xtests/tst-pam_limits1.c4
1 files changed, 2 insertions, 2 deletions
diff --git a/xtests/tst-pam_limits1.c b/xtests/tst-pam_limits1.c
index 6331450a..cf025d3d 100644
--- a/xtests/tst-pam_limits1.c
+++ b/xtests/tst-pam_limits1.c
@@ -132,8 +132,8 @@ main(int argc, char *argv[])
if (rlim.rlim_cur != 1 && rlim.rlim_max != 40)
{
if (debug)
- fprintf (stderr, "pam_limits1: getrlimit failed, soft=%d, hard=%d\n",
- rlim.rlim_cur, rlim.rlim_max);
+ fprintf (stderr, "pam_limits1: getrlimit failed, soft=%u, hard=%u\n",
+ (unsigned int) rlim.rlim_cur, (unsigned int) rlim.rlim_max);
return 1;
}