summaryrefslogtreecommitdiff
path: root/xtests
diff options
context:
space:
mode:
authorSteve Langasek <steve.langasek@ubuntu.com>2019-01-03 21:22:21 -0800
committerSteve Langasek <steve.langasek@ubuntu.com>2019-01-03 21:22:45 -0800
commit795badba7f95e737f979917859cd32c9bd47bcad (patch)
tree212a6a00baa11e9d0ca7bc27b12420d1dce6f07c /xtests
parentc55c14c5c6762139ec6695d84ea0e2e917da5264 (diff)
parentba315ae8effdcad591608c99452dad05c4cf20ab (diff)
New upstream version 1.1.8
Diffstat (limited to 'xtests')
-rw-r--r--xtests/Makefile.am4
-rw-r--r--xtests/Makefile.in141
-rw-r--r--xtests/group.conf1
-rw-r--r--xtests/tst-pam_access1.pamd1
-rw-r--r--xtests/tst-pam_access2.pamd1
-rw-r--r--xtests/tst-pam_access3.pamd1
-rw-r--r--xtests/tst-pam_access4.pamd1
-rw-r--r--xtests/tst-pam_authfail.c4
-rw-r--r--xtests/tst-pam_authsucceed.c4
-rw-r--r--xtests/tst-pam_dispatch3.pamd1
-rw-r--r--xtests/tst-pam_group1.pamd1
-rw-r--r--xtests/tst-pam_limits1.pamd1
-rw-r--r--xtests/tst-pam_pwhistory1.pamd3
-rw-r--r--[-rwxr-xr-x]xtests/tst-pam_pwhistory1.sh0
-rw-r--r--xtests/tst-pam_substack1.pamd2
-rw-r--r--xtests/tst-pam_unix1.pamd1
-rw-r--r--xtests/tst-pam_unix2.pamd1
-rw-r--r--xtests/tst-pam_unix3.pamd1
-rw-r--r--xtests/tst-pam_unix4.pamd1
19 files changed, 116 insertions, 54 deletions
diff --git a/xtests/Makefile.am b/xtests/Makefile.am
index 498a9fca..a6d6f8db 100644
--- a/xtests/Makefile.am
+++ b/xtests/Makefile.am
@@ -4,8 +4,8 @@
AM_CFLAGS = -DLIBPAM_COMPILE -I$(top_srcdir)/libpam/include \
-I$(top_srcdir)/libpamc/include -I$(top_srcdir)/libpam_misc/include
-AM_LDFLAGS = -L$(top_builddir)/libpam -lpam \
- -L$(top_builddir)/libpam_misc -lpam_misc
+LDADD = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
CLEANFILES = *~ $(XTESTS)
diff --git a/xtests/Makefile.in b/xtests/Makefile.in
index c91b3dd2..ee2d43ac 100644
--- a/xtests/Makefile.in
+++ b/xtests/Makefile.in
@@ -1,8 +1,9 @@
-# Makefile.in generated by automake 1.10.1 from Makefile.am.
+# Makefile.in generated by automake 1.11.1 from Makefile.am.
# @configure_input@
# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
-# 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
+# 2003, 2004, 2005, 2006, 2007, 2008, 2009 Free Software Foundation,
+# Inc.
# This Makefile.in is free software; the Free Software Foundation
# gives unlimited permission to copy and/or distribute it,
# with or without modifications, as long as this notice is preserved.
@@ -19,8 +20,9 @@
#
VPATH = @srcdir@
pkgdatadir = $(datadir)/@PACKAGE@
-pkglibdir = $(libdir)/@PACKAGE@
pkgincludedir = $(includedir)/@PACKAGE@
+pkglibdir = $(libdir)/@PACKAGE@
+pkglibexecdir = $(libexecdir)/@PACKAGE@
am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
install_sh_DATA = $(install_sh) -c -m 644
install_sh_PROGRAM = $(install_sh) -c
@@ -40,7 +42,7 @@ subdir = xtests
DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
am__aclocal_m4_deps = $(top_srcdir)/m4/gettext.m4 \
- $(top_srcdir)/m4/iconv.m4 $(top_srcdir)/m4/intlmacosx.m4 \
+ $(top_srcdir)/m4/iconv.m4 \
$(top_srcdir)/m4/japhar_grep_cflags.m4 \
$(top_srcdir)/m4/jh_path_xml_catalog.m4 \
$(top_srcdir)/m4/ld-O1.m4 $(top_srcdir)/m4/ld-as-needed.m4 \
@@ -53,9 +55,10 @@ am__aclocal_m4_deps = $(top_srcdir)/m4/gettext.m4 \
$(top_srcdir)/m4/progtest.m4 $(top_srcdir)/configure.in
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
$(ACLOCAL_M4)
-mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+mkinstalldirs = $(install_sh) -d
CONFIG_HEADER = $(top_builddir)/config.h
CONFIG_CLEAN_FILES =
+CONFIG_CLEAN_VPATH_FILES =
am__EXEEXT_1 = tst-pam_dispatch1$(EXEEXT) tst-pam_dispatch2$(EXEEXT) \
tst-pam_dispatch3$(EXEEXT) tst-pam_dispatch4$(EXEEXT) \
tst-pam_dispatch5$(EXEEXT) tst-pam_cracklib1$(EXEEXT) \
@@ -70,72 +73,117 @@ am__EXEEXT_1 = tst-pam_dispatch1$(EXEEXT) tst-pam_dispatch2$(EXEEXT) \
tst_pam_access1_SOURCES = tst-pam_access1.c
tst_pam_access1_OBJECTS = tst-pam_access1.$(OBJEXT)
tst_pam_access1_LDADD = $(LDADD)
+tst_pam_access1_DEPENDENCIES = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
tst_pam_access2_SOURCES = tst-pam_access2.c
tst_pam_access2_OBJECTS = tst-pam_access2.$(OBJEXT)
tst_pam_access2_LDADD = $(LDADD)
+tst_pam_access2_DEPENDENCIES = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
tst_pam_access3_SOURCES = tst-pam_access3.c
tst_pam_access3_OBJECTS = tst-pam_access3.$(OBJEXT)
tst_pam_access3_LDADD = $(LDADD)
+tst_pam_access3_DEPENDENCIES = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
tst_pam_access4_SOURCES = tst-pam_access4.c
tst_pam_access4_OBJECTS = tst-pam_access4.$(OBJEXT)
tst_pam_access4_LDADD = $(LDADD)
+tst_pam_access4_DEPENDENCIES = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
tst_pam_authfail_SOURCES = tst-pam_authfail.c
tst_pam_authfail_OBJECTS = tst-pam_authfail.$(OBJEXT)
tst_pam_authfail_LDADD = $(LDADD)
+tst_pam_authfail_DEPENDENCIES = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
tst_pam_authsucceed_SOURCES = tst-pam_authsucceed.c
tst_pam_authsucceed_OBJECTS = tst-pam_authsucceed.$(OBJEXT)
tst_pam_authsucceed_LDADD = $(LDADD)
+tst_pam_authsucceed_DEPENDENCIES = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
tst_pam_cracklib1_SOURCES = tst-pam_cracklib1.c
tst_pam_cracklib1_OBJECTS = tst-pam_cracklib1.$(OBJEXT)
tst_pam_cracklib1_LDADD = $(LDADD)
+tst_pam_cracklib1_DEPENDENCIES = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
tst_pam_cracklib2_SOURCES = tst-pam_cracklib2.c
tst_pam_cracklib2_OBJECTS = tst-pam_cracklib2.$(OBJEXT)
tst_pam_cracklib2_LDADD = $(LDADD)
+tst_pam_cracklib2_DEPENDENCIES = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
tst_pam_dispatch1_SOURCES = tst-pam_dispatch1.c
tst_pam_dispatch1_OBJECTS = tst-pam_dispatch1.$(OBJEXT)
tst_pam_dispatch1_LDADD = $(LDADD)
+tst_pam_dispatch1_DEPENDENCIES = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
tst_pam_dispatch2_SOURCES = tst-pam_dispatch2.c
tst_pam_dispatch2_OBJECTS = tst-pam_dispatch2.$(OBJEXT)
tst_pam_dispatch2_LDADD = $(LDADD)
+tst_pam_dispatch2_DEPENDENCIES = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
tst_pam_dispatch3_SOURCES = tst-pam_dispatch3.c
tst_pam_dispatch3_OBJECTS = tst-pam_dispatch3.$(OBJEXT)
tst_pam_dispatch3_LDADD = $(LDADD)
+tst_pam_dispatch3_DEPENDENCIES = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
tst_pam_dispatch4_SOURCES = tst-pam_dispatch4.c
tst_pam_dispatch4_OBJECTS = tst-pam_dispatch4.$(OBJEXT)
tst_pam_dispatch4_LDADD = $(LDADD)
+tst_pam_dispatch4_DEPENDENCIES = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
tst_pam_dispatch5_SOURCES = tst-pam_dispatch5.c
tst_pam_dispatch5_OBJECTS = tst-pam_dispatch5.$(OBJEXT)
tst_pam_dispatch5_LDADD = $(LDADD)
+tst_pam_dispatch5_DEPENDENCIES = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
tst_pam_group1_SOURCES = tst-pam_group1.c
tst_pam_group1_OBJECTS = tst-pam_group1.$(OBJEXT)
tst_pam_group1_LDADD = $(LDADD)
+tst_pam_group1_DEPENDENCIES = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
tst_pam_limits1_SOURCES = tst-pam_limits1.c
tst_pam_limits1_OBJECTS = tst-pam_limits1.$(OBJEXT)
tst_pam_limits1_LDADD = $(LDADD)
+tst_pam_limits1_DEPENDENCIES = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
tst_pam_pwhistory1_SOURCES = tst-pam_pwhistory1.c
tst_pam_pwhistory1_OBJECTS = tst-pam_pwhistory1.$(OBJEXT)
tst_pam_pwhistory1_LDADD = $(LDADD)
+tst_pam_pwhistory1_DEPENDENCIES = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
tst_pam_succeed_if1_SOURCES = tst-pam_succeed_if1.c
tst_pam_succeed_if1_OBJECTS = tst-pam_succeed_if1.$(OBJEXT)
tst_pam_succeed_if1_LDADD = $(LDADD)
+tst_pam_succeed_if1_DEPENDENCIES = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
tst_pam_time1_SOURCES = tst-pam_time1.c
tst_pam_time1_OBJECTS = tst-pam_time1.$(OBJEXT)
tst_pam_time1_LDADD = $(LDADD)
+tst_pam_time1_DEPENDENCIES = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
tst_pam_unix1_SOURCES = tst-pam_unix1.c
tst_pam_unix1_OBJECTS = tst-pam_unix1.$(OBJEXT)
tst_pam_unix1_LDADD = $(LDADD)
+tst_pam_unix1_DEPENDENCIES = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
tst_pam_unix2_SOURCES = tst-pam_unix2.c
tst_pam_unix2_OBJECTS = tst-pam_unix2.$(OBJEXT)
tst_pam_unix2_LDADD = $(LDADD)
+tst_pam_unix2_DEPENDENCIES = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
tst_pam_unix3_SOURCES = tst-pam_unix3.c
tst_pam_unix3_OBJECTS = tst-pam_unix3.$(OBJEXT)
tst_pam_unix3_LDADD = $(LDADD)
+tst_pam_unix3_DEPENDENCIES = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
tst_pam_unix4_SOURCES = tst-pam_unix4.c
tst_pam_unix4_OBJECTS = tst-pam_unix4.$(OBJEXT)
tst_pam_unix4_LDADD = $(LDADD)
+tst_pam_unix4_DEPENDENCIES = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)
-depcomp = $(SHELL) $(top_srcdir)/depcomp
+depcomp = $(SHELL) $(top_srcdir)/build-aux/depcomp
am__depfiles_maybe = depfiles
+am__mv = mv -f
COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
LTCOMPILE = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
@@ -192,7 +240,6 @@ EGREP = @EGREP@
EXEEXT = @EXEEXT@
FGREP = @FGREP@
FO2PDF = @FO2PDF@
-GETTEXT_MACRO_VERSION = @GETTEXT_MACRO_VERSION@
GMSGFMT = @GMSGFMT@
GMSGFMT_015 = @GMSGFMT_015@
GREP = @GREP@
@@ -216,7 +263,6 @@ LIBDB = @LIBDB@
LIBDL = @LIBDL@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
-LIBNSL = @LIBNSL@
LIBOBJS = @LIBOBJS@
LIBPRELUDE_CFLAGS = @LIBPRELUDE_CFLAGS@
LIBPRELUDE_CONFIG = @LIBPRELUDE_CONFIG@
@@ -238,6 +284,8 @@ MKDIR_P = @MKDIR_P@
MSGFMT = @MSGFMT@
MSGFMT_015 = @MSGFMT_015@
MSGMERGE = @MSGMERGE@
+NIS_CFLAGS = @NIS_CFLAGS@
+NIS_LIBS = @NIS_LIBS@
NM = @NM@
NMEDIT = @NMEDIT@
OBJDUMP = @OBJDUMP@
@@ -249,10 +297,12 @@ PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
PACKAGE_NAME = @PACKAGE_NAME@
PACKAGE_STRING = @PACKAGE_STRING@
PACKAGE_TARNAME = @PACKAGE_TARNAME@
+PACKAGE_URL = @PACKAGE_URL@
PACKAGE_VERSION = @PACKAGE_VERSION@
PATH_SEPARATOR = @PATH_SEPARATOR@
PIE_CFLAGS = @PIE_CFLAGS@
PIE_LDFLAGS = @PIE_LDFLAGS@
+PKG_CONFIG = @PKG_CONFIG@
POSUB = @POSUB@
RANLIB = @RANLIB@
SCONFIGDIR = @SCONFIGDIR@
@@ -265,7 +315,6 @@ USE_NLS = @USE_NLS@
VERSION = @VERSION@
XGETTEXT = @XGETTEXT@
XGETTEXT_015 = @XGETTEXT_015@
-XGETTEXT_EXTRA_OPTIONS = @XGETTEXT_EXTRA_OPTIONS@
XMLCATALOG = @XMLCATALOG@
XMLLINT = @XMLLINT@
XML_CATALOG_FILE = @XML_CATALOG_FILE@
@@ -307,6 +356,8 @@ install_sh = @install_sh@
libc_cv_fpie = @libc_cv_fpie@
libdir = @libdir@
libexecdir = @libexecdir@
+libtirpc_CFLAGS = @libtirpc_CFLAGS@
+libtirpc_LIBS = @libtirpc_LIBS@
localedir = @localedir@
localstatedir = @localstatedir@
lt_ECHO = @lt_ECHO@
@@ -332,8 +383,8 @@ top_srcdir = @top_srcdir@
AM_CFLAGS = -DLIBPAM_COMPILE -I$(top_srcdir)/libpam/include \
-I$(top_srcdir)/libpamc/include -I$(top_srcdir)/libpam_misc/include
-AM_LDFLAGS = -L$(top_builddir)/libpam -lpam \
- -L$(top_builddir)/libpam_misc -lpam_misc
+LDADD = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
CLEANFILES = *~ $(XTESTS)
EXTRA_DIST = run-xtests.sh tst-pam_dispatch1.pamd tst-pam_dispatch2.pamd \
@@ -381,14 +432,14 @@ $(srcdir)/Makefile.in: $(srcdir)/Makefile.am $(am__configure_deps)
@for dep in $?; do \
case '$(am__configure_deps)' in \
*$$dep*) \
- cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh \
- && exit 0; \
+ ( cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh ) \
+ && { if test -f $@; then exit 0; else break; fi; }; \
exit 1;; \
esac; \
done; \
- echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu xtests/Makefile'; \
- cd $(top_srcdir) && \
- $(AUTOMAKE) --gnu xtests/Makefile
+ echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu xtests/Makefile'; \
+ $(am__cd) $(top_srcdir) && \
+ $(AUTOMAKE) --gnu xtests/Makefile
.PRECIOUS: Makefile
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
@case '$?' in \
@@ -406,6 +457,7 @@ $(top_srcdir)/configure: $(am__configure_deps)
cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
$(ACLOCAL_M4): $(am__aclocal_m4_deps)
cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
+$(am__aclocal_m4_deps):
tst-pam_access1$(EXEEXT): $(tst_pam_access1_OBJECTS) $(tst_pam_access1_DEPENDENCIES)
@rm -f tst-pam_access1$(EXEEXT)
$(LINK) $(tst_pam_access1_OBJECTS) $(tst_pam_access1_LDADD) $(LIBS)
@@ -504,21 +556,21 @@ distclean-compile:
.c.o:
@am__fastdepCC_TRUE@ $(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
-@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
+@am__fastdepCC_TRUE@ $(am__mv) $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
@am__fastdepCC_FALSE@ $(COMPILE) -c $<
.c.obj:
@am__fastdepCC_TRUE@ $(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ `$(CYGPATH_W) '$<'`
-@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
+@am__fastdepCC_TRUE@ $(am__mv) $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
@am__fastdepCC_FALSE@ $(COMPILE) -c `$(CYGPATH_W) '$<'`
.c.lo:
@am__fastdepCC_TRUE@ $(LTCOMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
-@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Plo
+@am__fastdepCC_TRUE@ $(am__mv) $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Plo
@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='$<' object='$@' libtool=yes @AMDEPBACKSLASH@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
@am__fastdepCC_FALSE@ $(LTCOMPILE) -c -o $@ $<
@@ -534,14 +586,14 @@ ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
unique=`for i in $$list; do \
if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
done | \
- $(AWK) '{ files[$$0] = 1; nonemtpy = 1; } \
+ $(AWK) '{ files[$$0] = 1; nonempty = 1; } \
END { if (nonempty) { for (i in files) print i; }; }'`; \
mkid -fID $$unique
tags: TAGS
TAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
$(TAGS_FILES) $(LISP)
- tags=; \
+ set x; \
here=`pwd`; \
list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
unique=`for i in $$list; do \
@@ -549,29 +601,34 @@ TAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
done | \
$(AWK) '{ files[$$0] = 1; nonempty = 1; } \
END { if (nonempty) { for (i in files) print i; }; }'`; \
- if test -z "$(ETAGS_ARGS)$$tags$$unique"; then :; else \
+ shift; \
+ if test -z "$(ETAGS_ARGS)$$*$$unique"; then :; else \
test -n "$$unique" || unique=$$empty_fix; \
- $(ETAGS) $(ETAGSFLAGS) $(AM_ETAGSFLAGS) $(ETAGS_ARGS) \
- $$tags $$unique; \
+ if test $$# -gt 0; then \
+ $(ETAGS) $(ETAGSFLAGS) $(AM_ETAGSFLAGS) $(ETAGS_ARGS) \
+ "$$@" $$unique; \
+ else \
+ $(ETAGS) $(ETAGSFLAGS) $(AM_ETAGSFLAGS) $(ETAGS_ARGS) \
+ $$unique; \
+ fi; \
fi
ctags: CTAGS
CTAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
$(TAGS_FILES) $(LISP)
- tags=; \
list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
unique=`for i in $$list; do \
if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
done | \
$(AWK) '{ files[$$0] = 1; nonempty = 1; } \
END { if (nonempty) { for (i in files) print i; }; }'`; \
- test -z "$(CTAGS_ARGS)$$tags$$unique" \
+ test -z "$(CTAGS_ARGS)$$unique" \
|| $(CTAGS) $(CTAGSFLAGS) $(AM_CTAGSFLAGS) $(CTAGS_ARGS) \
- $$tags $$unique
+ $$unique
GTAGS:
here=`$(am__cd) $(top_builddir) && pwd` \
- && cd $(top_srcdir) \
- && gtags -i $(GTAGS_ARGS) $$here
+ && $(am__cd) $(top_srcdir) \
+ && gtags -i $(GTAGS_ARGS) "$$here"
distclean-tags:
-rm -f TAGS ID GTAGS GRTAGS GSYMS GPATH tags
@@ -592,13 +649,17 @@ distdir: $(DISTFILES)
if test -f $$file || test -d $$file; then d=.; else d=$(srcdir); fi; \
if test -d $$d/$$file; then \
dir=`echo "/$$file" | sed -e 's,/[^/]*$$,,'`; \
+ if test -d "$(distdir)/$$file"; then \
+ find "$(distdir)/$$file" -type d ! -perm -700 -exec chmod u+rwx {} \;; \
+ fi; \
if test -d $(srcdir)/$$file && test $$d != $(srcdir); then \
- cp -pR $(srcdir)/$$file $(distdir)$$dir || exit 1; \
+ cp -fpR $(srcdir)/$$file "$(distdir)$$dir" || exit 1; \
+ find "$(distdir)/$$file" -type d ! -perm -700 -exec chmod u+rwx {} \;; \
fi; \
- cp -pR $$d/$$file $(distdir)$$dir || exit 1; \
+ cp -fpR $$d/$$file "$(distdir)$$dir" || exit 1; \
else \
- test -f $(distdir)/$$file \
- || cp -p $$d/$$file $(distdir)/$$file \
+ test -f "$(distdir)/$$file" \
+ || cp -p $$d/$$file "$(distdir)/$$file" \
|| exit 1; \
fi; \
done
@@ -627,6 +688,7 @@ clean-generic:
distclean-generic:
-test -z "$(CONFIG_CLEAN_FILES)" || rm -f $(CONFIG_CLEAN_FILES)
+ -test . = "$(srcdir)" || test -z "$(CONFIG_CLEAN_VPATH_FILES)" || rm -f $(CONFIG_CLEAN_VPATH_FILES)
maintainer-clean-generic:
@echo "This command is intended for maintainers to use"
@@ -647,6 +709,8 @@ dvi-am:
html: html-am
+html-am:
+
info: info-am
info-am:
@@ -655,18 +719,28 @@ install-data-am:
install-dvi: install-dvi-am
+install-dvi-am:
+
install-exec-am:
install-html: install-html-am
+install-html-am:
+
install-info: install-info-am
+install-info-am:
+
install-man:
install-pdf: install-pdf-am
+install-pdf-am:
+
install-ps: install-ps-am
+install-ps-am:
+
installcheck-am:
maintainer-clean: maintainer-clean-am
@@ -707,6 +781,7 @@ uninstall-am:
xtests: $(XTESTS) run-xtests.sh
"$(srcdir)"/run-xtests.sh "$(srcdir)" ${XTESTS} ${NOSRCTESTS}
+
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT:
diff --git a/xtests/group.conf b/xtests/group.conf
index 04fe3ef7..2cb34877 100644
--- a/xtests/group.conf
+++ b/xtests/group.conf
@@ -1,3 +1,2 @@
tst-pam_group1;tty1;tstpamgrp;Al0000-2400;tstpamgrpg
-
diff --git a/xtests/tst-pam_access1.pamd b/xtests/tst-pam_access1.pamd
index f47ec34f..a70f2d9c 100644
--- a/xtests/tst-pam_access1.pamd
+++ b/xtests/tst-pam_access1.pamd
@@ -3,4 +3,3 @@ auth required pam_access.so nodefgroup
account required pam_permit.so
password required pam_permit.so
session required pam_permit.so
-
diff --git a/xtests/tst-pam_access2.pamd b/xtests/tst-pam_access2.pamd
index f47ec34f..a70f2d9c 100644
--- a/xtests/tst-pam_access2.pamd
+++ b/xtests/tst-pam_access2.pamd
@@ -3,4 +3,3 @@ auth required pam_access.so nodefgroup
account required pam_permit.so
password required pam_permit.so
session required pam_permit.so
-
diff --git a/xtests/tst-pam_access3.pamd b/xtests/tst-pam_access3.pamd
index f47ec34f..a70f2d9c 100644
--- a/xtests/tst-pam_access3.pamd
+++ b/xtests/tst-pam_access3.pamd
@@ -3,4 +3,3 @@ auth required pam_access.so nodefgroup
account required pam_permit.so
password required pam_permit.so
session required pam_permit.so
-
diff --git a/xtests/tst-pam_access4.pamd b/xtests/tst-pam_access4.pamd
index f47ec34f..a70f2d9c 100644
--- a/xtests/tst-pam_access4.pamd
+++ b/xtests/tst-pam_access4.pamd
@@ -3,4 +3,3 @@ auth required pam_access.so nodefgroup
account required pam_permit.so
password required pam_permit.so
session required pam_permit.so
-
diff --git a/xtests/tst-pam_authfail.c b/xtests/tst-pam_authfail.c
index afdbd6a4..0e7d8087 100644
--- a/xtests/tst-pam_authfail.c
+++ b/xtests/tst-pam_authfail.c
@@ -60,14 +60,14 @@ main(int argc, char *argv[])
if (argc > 2) {
stack = argv[2];
}
-
+
if (argc > 1) {
if (strcmp (argv[1], "-d") == 0)
debug = 1;
else
stack = argv[1];
}
-
+
retval = pam_start(stack, user, &conv, &pamh);
if (retval != PAM_SUCCESS)
diff --git a/xtests/tst-pam_authsucceed.c b/xtests/tst-pam_authsucceed.c
index 8666f3f7..c0ee8023 100644
--- a/xtests/tst-pam_authsucceed.c
+++ b/xtests/tst-pam_authsucceed.c
@@ -60,14 +60,14 @@ main(int argc, char *argv[])
if (argc > 2) {
stack = argv[2];
}
-
+
if (argc > 1) {
if (strcmp (argv[1], "-d") == 0)
debug = 1;
else
stack = argv[1];
}
-
+
retval = pam_start(stack, user, &conv, &pamh);
if (retval != PAM_SUCCESS)
diff --git a/xtests/tst-pam_dispatch3.pamd b/xtests/tst-pam_dispatch3.pamd
index 8172c5f2..7f290aba 100644
--- a/xtests/tst-pam_dispatch3.pamd
+++ b/xtests/tst-pam_dispatch3.pamd
@@ -3,4 +3,3 @@ auth optional pam_debug.so auth=auth_err
auth sufficient pam_debug.so auth=success
auth required pam_debug.so auth=perm_denied
account required pam_debug.so acct=acct_expired
-
diff --git a/xtests/tst-pam_group1.pamd b/xtests/tst-pam_group1.pamd
index d78f3a6c..e75d0d1c 100644
--- a/xtests/tst-pam_group1.pamd
+++ b/xtests/tst-pam_group1.pamd
@@ -4,4 +4,3 @@ auth required pam_permit.so
account required pam_permit.so
password required pam_permit.so
session required pam_permit.so
-
diff --git a/xtests/tst-pam_limits1.pamd b/xtests/tst-pam_limits1.pamd
index 206ef1f7..7b1771c4 100644
--- a/xtests/tst-pam_limits1.pamd
+++ b/xtests/tst-pam_limits1.pamd
@@ -3,4 +3,3 @@ auth required pam_permit.so
account required pam_permit.so
password required pam_permit.so
session required pam_limits.so
-
diff --git a/xtests/tst-pam_pwhistory1.pamd b/xtests/tst-pam_pwhistory1.pamd
index e096cc4f..d60db7cb 100644
--- a/xtests/tst-pam_pwhistory1.pamd
+++ b/xtests/tst-pam_pwhistory1.pamd
@@ -1,7 +1,6 @@
#%PAM-1.0
auth required pam_permit.so
account required pam_permit.so
-password required pam_pwhistory.so remember=10 retry=1
+password required pam_pwhistory.so remember=10 retry=1 enforce_for_root
password required pam_unix.so use_authtok md5
session required pam_permit.so
-
diff --git a/xtests/tst-pam_pwhistory1.sh b/xtests/tst-pam_pwhistory1.sh
index ddb3b8b1..ddb3b8b1 100755..100644
--- a/xtests/tst-pam_pwhistory1.sh
+++ b/xtests/tst-pam_pwhistory1.sh
diff --git a/xtests/tst-pam_substack1.pamd b/xtests/tst-pam_substack1.pamd
index 6eab233e..8dfe1b82 100644
--- a/xtests/tst-pam_substack1.pamd
+++ b/xtests/tst-pam_substack1.pamd
@@ -1,5 +1,5 @@
#%PAM-1.0
-# Even if the substack succeeds with sufficient
+# Even if the substack succeeds with sufficient
# the whole stack should fail.
auth substack tst-pam_substack1a
auth required pam_debug.so auth=auth_err
diff --git a/xtests/tst-pam_unix1.pamd b/xtests/tst-pam_unix1.pamd
index 1a2990c7..6cd67b6a 100644
--- a/xtests/tst-pam_unix1.pamd
+++ b/xtests/tst-pam_unix1.pamd
@@ -3,4 +3,3 @@ auth required pam_unix.so
account required pam_unix.so
password required pam_unix.so
session required pam_unix.so
-
diff --git a/xtests/tst-pam_unix2.pamd b/xtests/tst-pam_unix2.pamd
index 1a2990c7..6cd67b6a 100644
--- a/xtests/tst-pam_unix2.pamd
+++ b/xtests/tst-pam_unix2.pamd
@@ -3,4 +3,3 @@ auth required pam_unix.so
account required pam_unix.so
password required pam_unix.so
session required pam_unix.so
-
diff --git a/xtests/tst-pam_unix3.pamd b/xtests/tst-pam_unix3.pamd
index 1a2990c7..6cd67b6a 100644
--- a/xtests/tst-pam_unix3.pamd
+++ b/xtests/tst-pam_unix3.pamd
@@ -3,4 +3,3 @@ auth required pam_unix.so
account required pam_unix.so
password required pam_unix.so
session required pam_unix.so
-
diff --git a/xtests/tst-pam_unix4.pamd b/xtests/tst-pam_unix4.pamd
index 4dc414fc..1affa8e1 100644
--- a/xtests/tst-pam_unix4.pamd
+++ b/xtests/tst-pam_unix4.pamd
@@ -3,4 +3,3 @@ auth required pam_unix.so
account required pam_unix.so
password required pam_unix.so debug
session required pam_unix.so
-