summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog6
-rw-r--r--Makefile.am7
-rw-r--r--doc/Makefile.am24
-rw-r--r--doc/adg/Makefile.am26
-rw-r--r--doc/index.html18
-rw-r--r--doc/mwg/Makefile.am20
-rw-r--r--doc/pdf/.cvsignore3
-rw-r--r--doc/pdf/README3
-rw-r--r--doc/ps/.cvsignore3
-rw-r--r--doc/ps/README3
-rw-r--r--doc/sag/Makefile.am26
-rw-r--r--doc/txts/.cvsignore3
-rw-r--r--doc/txts/README3
13 files changed, 108 insertions, 37 deletions
diff --git a/ChangeLog b/ChangeLog
index dfbb23f3..11c0f023 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -28,8 +28,12 @@
* doc/Makefile.am: Remove references to sgml, add sag, adg and mwg
directories.
-
* doc/modules: Remove directory.
+ * doc/html: Remove directory.
+ * doc/ps: Remove directory.
+ * doc/pdf: Remove directory.
+ * doc/txts: Remove directory.
+ * doc/index.html: Moved from html directory to here.
2006-06-28 Thorsten Kukuk <kukuk@thkukuk.de>
diff --git a/Makefile.am b/Makefile.am
index 03b1f2d5..9dbe47bc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,4 +24,11 @@ release: dist releasedocs
release-docs: releasedocs
releasedocs:
+ rm -rf Linux-PAM-$(VERSION)-docs
+ mkdir -p Linux-PAM-$(VERSION)-docs
make -C doc releasedocs
+ tar zfc Linux-PAM-$(VERSION)-docs.tar.gz \
+ Linux-PAM-$(VERSION)-docs/*
+ tar jfc Linux-PAM-$(VERSION)-docs.tar.bz2 \
+ Linux-PAM-$(VERSION)-docs/*
+ rm -rf Linux-PAM-$(VERSION)-docs
diff --git a/doc/Makefile.am b/doc/Makefile.am
index c1e2586f..2195783a 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -6,7 +6,7 @@ SUBDIRS = man specs sag adg mwg
CLEANFILES = *~
-EXTRA_DIST = pdf/README html/index.html txts/README
+EXTRA_DIST = index.html
#######################################################
@@ -26,11 +26,17 @@ install-data-local:
done
releasedocs: all
- tar zvfc ../Linux-PAM-$(VERSION)-docs.tar.gz \
- --exclude CVS --exclude .cvsignore --exclude '.#*' \
- --exclude README html txts pdf \
- specs/draft-morgan-pam-current.txt specs/rfc86.0.txt
- tar jvfc ../Linux-PAM-$(VERSION)-docs.tar.bz2 \
- --exclude CVS --exclude .cvsignore --exclude '.#*' \
- --exclude README html ps txts pdf \
- specs/draft-morgan-pam-current.txt specs/rfc86.0.txt
+ mkdir -p $(top_builddir)/Linux-PAM-$(VERSION)-docs/html
+ mkdir -p $(top_builddir)/Linux-PAM-$(VERSION)-docs/pdf
+ mkdir -p $(top_builddir)/Linux-PAM-$(VERSION)-docs/txt
+ mkdir -p $(top_builddir)/Linux-PAM-$(VERSION)-docs/specs
+ cp -av $(srcdir)/index.html \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/html/
+ cp -av specs/draft-morgan-pam-current.txt \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/specs/
+ cp -av specs/rfc86.0.txt \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/specs/
+ make -C sag releasedocs
+ make -C adg releasedocs
+ make -C mwg releasedocs
+
diff --git a/doc/adg/Makefile.am b/doc/adg/Makefile.am
index 6eabeb5a..419a8c6b 100644
--- a/doc/adg/Makefile.am
+++ b/doc/adg/Makefile.am
@@ -6,7 +6,7 @@ CLEANFILES = Linux-PAM_ADG.fo *~
EXTRA_DIST = $(XMLS)
-XMLS = Linux-PAM_ADG.xml $(shell ls pam_*.xml)
+XMLS = Linux-PAM_ADG.xml $(shell ls $(srcdir)/pam_*.xml)
if ENABLE_REGENERATE_MAN
MAINTAINERCLEANFILES = Linux-PAM_ADG.txt Linux-PAM_ADG.pdf html/*.html
@@ -21,7 +21,7 @@ if ENABLE_GENERATE_PDF
--stringparam section.label.includes.component.label 1 \
--stringparam toc.max.depth 3 --xinclude --nonet \
http://docbook.sourceforge.net/release/xsl/current/fo/docbook.xsl $< > Linux-PAM_ADG.fo
- $(FO2PDF) Linux-PAM_ADG.fo $(srcdir)/$@
+ $(FO2PDF) Linux-PAM_ADG.fo $@
else
echo "No fo2pdf processor installed, skip PDF generation"
endif
@@ -32,10 +32,10 @@ Linux-PAM_ADG.txt: $(XMLS)
--stringparam section.autolabel 1 \
--stringparam section.label.includes.component.label 1 \
--stringparam toc.max.depth 3 --xinclude --nonet \
- http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl $< | $(BROWSER) > $(srcdir)/$@
+ http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl $< | $(BROWSER) > $@
html/Linux-PAM_ADG.html: $(XMLS)
- @test -d $(srcdir)/html || mkdir -p $(srcdir)/html
+ @test -d html || mkdir -p html
$(XMLLINT) --nonet --xinclude --postvalid --noent --noout $<
$(XSLTPROC) --stringparam base.dir html/ \
--stringparam root.filename Linux-PAM_ADG \
@@ -46,3 +46,21 @@ html/Linux-PAM_ADG.html: $(XMLS)
--stringparam toc.max.depth 3 --xinclude --nonet \
http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl $<
endif
+
+releasedocs: all
+ test -f html/Linux-PAM_ADG.html && \
+ cp -ap html/Linux-PAM_ADG.html html/adg-*.html \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/html/ || \
+ cp -ap $(srcdir)/html/Linux-PAM_ADG.html \
+ $(srcdir)/html/adg-*.html \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/html/
+ test -f Linux-PAM_ADG.txt && \
+ cp -p Linux-PAM_ADG.txt \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/txt/ || \
+ cp -p $(srcdir)/Linux-PAM_ADG.txt \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/txt/
+ test -f Linux-PAM_ADG.pdf && \
+ cp -p Linux-PAM_ADG.pdf \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/pdf/ || \
+ cp -p $(srcdir)/Linux-PAM_ADG.pdf \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/pdf/
diff --git a/doc/index.html b/doc/index.html
new file mode 100644
index 00000000..9e607b95
--- /dev/null
+++ b/doc/index.html
@@ -0,0 +1,18 @@
+
+<HTML>
+<HEAD>
+<TITLE>Linux-PAM - Pluggable Authentication Modules for Linux</TITLE>
+</HEAD>
+<BODY>
+
+<p>
+Here is the documentation for Linux-PAM. As you will see it is
+currently not complete. However, in order of decreasing length:
+
+<ul>
+<li> <a href="Linux-PAM_SAG.html">The System Administrators' Guide</a>
+<li> <a href="Linux-PAM_MWG.html">The Module Writers' Guide</a>
+<li> <a href="Linux-PAM_ADG.html">The Application developers' Guide</a>
+</ul>
+
+</BODY>
diff --git a/doc/mwg/Makefile.am b/doc/mwg/Makefile.am
index 249dfbb7..ee650f64 100644
--- a/doc/mwg/Makefile.am
+++ b/doc/mwg/Makefile.am
@@ -6,7 +6,7 @@ CLEANFILES = Linux-PAM_MWG.fo *~
EXTRA_DIST = $(XMLS)
-XMLS = Linux-PAM_MWG.xml $(shell ls pam_*.xml)
+XMLS = Linux-PAM_MWG.xml $(shell ls $(srcdir)/pam_*.xml)
if ENABLE_REGENERATE_MAN
MAINTAINERCLEANFILES = Linux-PAM_MWG.txt Linux-PAM_MWG.pdf html/*.html
@@ -46,3 +46,21 @@ html/Linux-PAM_MWG.html: $(XMLS)
--stringparam toc.max.depth 3 --xinclude --nonet \
http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl $<
endif
+
+releasedocs: all
+ test -f html/Linux-PAM_MWG.html && \
+ cp -ap html/Linux-PAM_MWG.html html/mwg-*.html \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/html/ || \
+ cp -ap $(srcdir)/html/Linux-PAM_MWG.html \
+ $(srcdir)/html/mwg-*.html \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/html/
+ test -f Linux-PAM_MWG.txt && \
+ cp -p Linux-PAM_MWG.txt \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/txt/ || \
+ cp -p $(srcdir)/Linux-PAM_MWG.txt \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/txt/
+ test -f Linux-PAM_MWG.pdf && \
+ cp -p Linux-PAM_MWG.pdf \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/pdf/ || \
+ cp -p $(srcdir)/Linux-PAM_MWG.pdf \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/pdf/
diff --git a/doc/pdf/.cvsignore b/doc/pdf/.cvsignore
deleted file mode 100644
index 76866b7e..00000000
--- a/doc/pdf/.cvsignore
+++ /dev/null
@@ -1,3 +0,0 @@
-*.pdf
-Makefile
-Makefile.in
diff --git a/doc/pdf/README b/doc/pdf/README
deleted file mode 100644
index 82efcd46..00000000
--- a/doc/pdf/README
+++ /dev/null
@@ -1,3 +0,0 @@
-$Id$
-
-a directory for PDF versions of the documentation
diff --git a/doc/ps/.cvsignore b/doc/ps/.cvsignore
deleted file mode 100644
index 442d5daf..00000000
--- a/doc/ps/.cvsignore
+++ /dev/null
@@ -1,3 +0,0 @@
-pam*.ps
-Makefile
-Makefile.in
diff --git a/doc/ps/README b/doc/ps/README
deleted file mode 100644
index 32a833f6..00000000
--- a/doc/ps/README
+++ /dev/null
@@ -1,3 +0,0 @@
-$Id$
-
-this is the directory for the PostScript documentation
diff --git a/doc/sag/Makefile.am b/doc/sag/Makefile.am
index f8d7c5f9..2e81709b 100644
--- a/doc/sag/Makefile.am
+++ b/doc/sag/Makefile.am
@@ -6,7 +6,7 @@ CLEANFILES = Linux-PAM_SAG.fo *~
EXTRA_DIST = $(XMLS)
-XMLS = Linux-PAM_SAG.xml $(shell ls pam_*.xml)
+XMLS = Linux-PAM_SAG.xml $(shell ls $(srcdir)/pam_*.xml)
if ENABLE_REGENERATE_MAN
MAINTAINERCLEANFILES = Linux-PAM_SAG.txt Linux-PAM_SAG.pdf html/*.html
@@ -21,7 +21,7 @@ if ENABLE_GENERATE_PDF
--stringparam section.label.includes.component.label 1 \
--stringparam toc.max.depth 2 --xinclude --nonet \
http://docbook.sourceforge.net/release/xsl/current/fo/docbook.xsl $< > Linux-PAM_SAG.fo
- $(FO2PDF) Linux-PAM_SAG.fo $(srcdir)/$@
+ $(FO2PDF) Linux-PAM_SAG.fo $@
else
echo "No fo2pdf processor installed, skip PDF generation"
endif
@@ -32,10 +32,10 @@ Linux-PAM_SAG.txt: $(XMLS)
--stringparam section.autolabel 1 \
--stringparam section.label.includes.component.label 1 \
--stringparam toc.max.depth 2 --xinclude --nonet \
- http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl $< | $(BROWSER) > $(srcdir)/$@
+ http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl $< | $(BROWSER) > $@
html/Linux-PAM_SAG.html: $(XMLS)
- @test -d $(srcdir)/html || mkdir -p $(srcdir)/html
+ @test -d html || mkdir -p html
$(XMLLINT) --nonet --xinclude --postvalid --noent --noout $<
$(XSLTPROC) --stringparam base.dir html/ \
--stringparam root.filename Linux-PAM_SAG \
@@ -46,3 +46,21 @@ html/Linux-PAM_SAG.html: $(XMLS)
--stringparam toc.max.depth 2 --xinclude --nonet \
http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl $<
endif
+
+releasedocs: all
+ test -f html/Linux-PAM_SAG.html && \
+ cp -ap html/Linux-PAM_SAG.html html/sag-*.html \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/html/ || \
+ cp -ap $(srcdir)/html/Linux-PAM_SAG.html \
+ $(srcdir)/html/sag-*.html \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/html/
+ test -f Linux-PAM_SAG.txt && \
+ cp -p Linux-PAM_SAG.txt \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/txt/ || \
+ cp -p $(srcdir)/Linux-PAM_SAG.txt \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/txt/
+ test -f Linux-PAM_SAG.pdf && \
+ cp -p Linux-PAM_SAG.pdf \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/pdf/ || \
+ cp -p $(srcdir)/Linux-PAM_SAG.pdf \
+ $(top_builddir)/Linux-PAM-$(VERSION)-docs/pdf/
diff --git a/doc/txts/.cvsignore b/doc/txts/.cvsignore
deleted file mode 100644
index 238919c1..00000000
--- a/doc/txts/.cvsignore
+++ /dev/null
@@ -1,3 +0,0 @@
-pam*.txt
-Makefile
-Makefile.in
diff --git a/doc/txts/README b/doc/txts/README
deleted file mode 100644
index 540b09b5..00000000
--- a/doc/txts/README
+++ /dev/null
@@ -1,3 +0,0 @@
-$Id$
-
-This is a directory for text versions of the pam documentation