summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.cvsignore1
-rw-r--r--ChangeLog3
-rw-r--r--configure.in6
3 files changed, 6 insertions, 4 deletions
diff --git a/.cvsignore b/.cvsignore
index 550f2ec9..c5eabb14 100644
--- a/.cvsignore
+++ b/.cvsignore
@@ -22,3 +22,4 @@ ltmain.sh
compile
missing
depcomp
+ylwrap
diff --git a/ChangeLog b/ChangeLog
index 94a15488..c2bf2ddb 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,8 @@
2006-12-18 Thorsten Kukuk <kukuk@thkukuk.de>
+ * configure.in: Fix ENOKEY check (specify errno.h as header
+ file to search in).
+
* configure.in: Add AM_PROG_CC_C_O.
* libpam/Makefile.am: Add content of AM_LDFLAGS to *_LDFLAGS.
* modules/pam_tally/Makefile.am: Likewise.
diff --git a/configure.in b/configure.in
index 08f1b4a4..eac7834c 100644
--- a/configure.in
+++ b/configure.in
@@ -466,10 +466,8 @@ dnl
dnl Check for the availability of the kernel key management facility
dnl - The pam_keyinit module only requires the syscalls, not the error codes
dnl
-have_key_syscalls=0
-AC_CHECK_DECL(__NR_keyctl, [have_key_syscalls=1],,[#include <sys/syscall.h>])
-have_key_errors=0
-AC_CHECK_DECL(ENOKEY, [have_key_errors=1])
+AC_CHECK_DECL(__NR_keyctl, [have_key_syscalls=1],[have_key_syscalls=0],[#include <sys/syscall.h>])
+AC_CHECK_DECL(ENOKEY, [have_key_errors=1],[have_key_errors=0],[#include <errno.h>])
HAVE_KEY_MANAGEMENT=0
if test $have_key_syscalls$have_key_errors = 11