summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog7
-rw-r--r--NEWS2
-rw-r--r--libpam_misc/misc_conv.c3
3 files changed, 10 insertions, 2 deletions
diff --git a/ChangeLog b/ChangeLog
index bbc4bb72..841b028f 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,10 @@
+2007-09-03 Steve Langasek <vorlon@debian.org>
+
+ * libpam_misc/misc_conv.c: don't block SIGINT in misc_conv; it's
+ perfectly valid to allow the user to interrupt at a prompt. If
+ an application wants prompts to not be interruptable, the
+ application should take responsibility for blocking SIGINT.
+
2007-09-02 Thorsten Kukuk <kukuk@thkukuk.de>
* examples/Makefile.am: Fix usage of LIBADD, LDADD and LDFLAGS.
diff --git a/NEWS b/NEWS
index 4432cf31..9b677047 100644
--- a/NEWS
+++ b/NEWS
@@ -1,5 +1,7 @@
Linux-PAM NEWS -- history of user-visible changes.
+* misc_conv no longer blocks SIGINT; applications that don't want
+ user-interruptable prompts should block SIGINT themselves.
Release 0.99.8.1
* Fix a regression in audit code introduced with last release
diff --git a/libpam_misc/misc_conv.c b/libpam_misc/misc_conv.c
index 8db24d74..3f82de1b 100644
--- a/libpam_misc/misc_conv.c
+++ b/libpam_misc/misc_conv.c
@@ -150,12 +150,11 @@ static int read_string(int echo, const char *prompt, char **retstr)
have_term = 1;
/*
- * We make a simple attempt to block TTY signals from terminating
+ * We make a simple attempt to block TTY signals from suspending
* the conversation without giving PAM a chance to clean up.
*/
sigemptyset(&nset);
- sigaddset(&nset, SIGINT);
sigaddset(&nset, SIGTSTP);
(void) sigprocmask(SIG_BLOCK, &nset, &oset);