summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--_pam_aconf.h.in3
-rwxr-xr-xconfigure5
-rw-r--r--configure.in2
-rw-r--r--modules/pam_rhosts/pam_rhosts_auth.c17
4 files changed, 13 insertions, 14 deletions
diff --git a/_pam_aconf.h.in b/_pam_aconf.h.in
index 68a39120..ae4b16e9 100644
--- a/_pam_aconf.h.in
+++ b/_pam_aconf.h.in
@@ -84,6 +84,9 @@
defined, we get it from unistd.h */
#undef HAVE_SYS_FSUID_H
+/* Do we have inttypes.h for uint32_t */
+#undef HAVE_INTTYPES_H
+
/* track all memory allocations and liberations */
#undef MEMORY_DEBUG
#ifdef MEMORY_DEBUG
diff --git a/configure b/configure
index 1d2c8591..0f90e74d 100755
--- a/configure
+++ b/configure
@@ -1320,7 +1320,7 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
LIBPAM_VERSION_MAJOR=0
-LIBPAM_VERSION_MINOR=79
+LIBPAM_VERSION_MINOR=80
@@ -5246,7 +5246,8 @@ fi
-for ac_header in fcntl.h limits.h malloc.h sys/file.h sys/ioctl.h sys/time.h syslog.h termio.h unistd.h sys/fsuid.h
+
+for ac_header in fcntl.h limits.h malloc.h sys/file.h sys/ioctl.h sys/time.h syslog.h termio.h unistd.h sys/fsuid.h inittypes.h
do
as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
if eval "test \"\${$as_ac_Header+set}\" = set"; then
diff --git a/configure.in b/configure.in
index 024d63e7..bc26474e 100644
--- a/configure.in
+++ b/configure.in
@@ -246,7 +246,7 @@ dnl Checks for header files.
AC_HEADER_DIRENT
AC_HEADER_STDC
AC_HEADER_SYS_WAIT
-AC_CHECK_HEADERS(fcntl.h limits.h malloc.h sys/file.h sys/ioctl.h sys/time.h syslog.h termio.h unistd.h sys/fsuid.h)
+AC_CHECK_HEADERS(fcntl.h limits.h malloc.h sys/file.h sys/ioctl.h sys/time.h syslog.h termio.h unistd.h sys/fsuid.h inittypes.h)
dnl Linux wants features.h in some of the source files.
AC_CHECK_HEADERS(features.h)
diff --git a/modules/pam_rhosts/pam_rhosts_auth.c b/modules/pam_rhosts/pam_rhosts_auth.c
index 979580ec..91446730 100644
--- a/modules/pam_rhosts/pam_rhosts_auth.c
+++ b/modules/pam_rhosts/pam_rhosts_auth.c
@@ -96,18 +96,13 @@ int innetgr(const char *, const char *, const char *,const char *);
#include <security/_pam_macros.h>
#include <security/_pam_modutil.h>
-#ifdef _ISOC9X_SOURCE
-#include <inttypes.h>
-#define U32 uint32_t
+#ifdef HAVE_INTTYPES_H
+ #include <inttypes.h>
+ #define U32 uint32_t
#else
-/* to the best of my knowledge, all modern UNIX boxes have 32 bits integers */
-#define U32 unsigned int
-#endif /* _ISOC9X_SOURCE */
-
-/* Use the C99 type; older platforms will need this to be typedef'ed
- elsewhere */
-#define U32 uint32_t
-
+ /* to the best of my knowledge, all modern UNIX boxes have 32 bits integers */
+ #define U32 unsigned int
+#endif /* HAVE_INTTYPES_H */
/*
* Options for this module