summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog10
-rw-r--r--NEWS12
-rw-r--r--configure.in2
-rw-r--r--libpam/Makefile.am2
4 files changed, 23 insertions, 3 deletions
diff --git a/ChangeLog b/ChangeLog
index 6f470dc6..247a4f14 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,13 @@
+2010-10-28 Thorsten Kukuk <kukuk@thkukuk.de>
+
+ * release version 1.1.3
+
+ * configure.in: Increase version to 1.1.3
+
+ * NEWS: document visible changes
+
+ * libpam/Makefile.am (libpam_la_LDFLAGS): Bump version number.
+
2010-10-27 Thorsten Kukuk <kukuk@thkukuk.de>
* doc/adg/Makefile.am: Use UTF-8 for html docu.
diff --git a/NEWS b/NEWS
index f68f8fd1..26fe1bd3 100644
--- a/NEWS
+++ b/NEWS
@@ -1,6 +1,16 @@
Linux-PAM NEWS -- history of user-visible changes.
+Release 1.1.3
+
+* pam_namespace: Clean environment for childs (CVE-2010-3853)
+* libpam: New interface to drop/regain privilegs
+* Drop root privilegs in pam_env, pam_mail and pam_xauth before
+ accessing user files (CVE-2010-3430, CVE-2010-3431)
+* pam_unix: Add minlen option, change default from 6 to 0
+* Documentation improvements
+* Lot of small bug fixes
+
Release 1.1.2
* pam_unix: Add minlen= option
@@ -14,7 +24,7 @@ Release 1.1.1
* Update translations
* pam_access: Revert netgroup match to original behavior, add new
syntax for adding the local hostname to netgroup match
-* libpam: Add new functions pam_get_authtok_noverify() and
+* libpam: Add new functions pam_get_authtok_noverify() and
pam_get_authtok_verify()
* Add sepermit.conf.5 manual page
* Lot of bug fixes
diff --git a/configure.in b/configure.in
index a6f659da..d09d753f 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
dnl Process this file with autoconf to produce a configure script.
AC_INIT
AC_CONFIG_SRCDIR([conf/pam_conv1/pam_conv_y.y])
-AM_INIT_AUTOMAKE("Linux-PAM", 1.1.2)
+AM_INIT_AUTOMAKE("Linux-PAM", 1.1.3)
AC_PREREQ(2.61)
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_MACRO_DIR([m4])
diff --git a/libpam/Makefile.am b/libpam/Makefile.am
index 57080fcf..3c7ae1d6 100644
--- a/libpam/Makefile.am
+++ b/libpam/Makefile.am
@@ -20,7 +20,7 @@ include_HEADERS = include/security/_pam_compat.h \
noinst_HEADERS = pam_prelude.h pam_private.h pam_tokens.h \
pam_modutil_private.h pam_static_modules.h
-libpam_la_LDFLAGS = -no-undefined -version-info 82:3:82
+libpam_la_LDFLAGS = -no-undefined -version-info 83:0:83
libpam_la_LIBADD = @LIBAUDIT@ $(LIBPRELUDE_LIBS) @LIBDL@
if STATIC_MODULES