summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog5
-rw-r--r--libpam/pam_audit.c3
2 files changed, 6 insertions, 2 deletions
diff --git a/ChangeLog b/ChangeLog
index 6a0cb63a..9a8394d7 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@
+2006-01-13 Dmitry V. Levin <ldv@altlinux.org>
+
+ * libpam/pam_audit.c (_pam_auditlog): Replace strerror(errno)
+ call with %m specifier.
+
2006-01-12 Thorsten Kukuk <kukuk@thkukuk.de>
* configure.in: Add check for -fpie/-pie
diff --git a/libpam/pam_audit.c b/libpam/pam_audit.c
index 7c067d9b..acf7da8b 100644
--- a/libpam/pam_audit.c
+++ b/libpam/pam_audit.c
@@ -56,8 +56,7 @@ _pam_auditlog(pam_handle_t *pamh, int action, int retval, int flags)
/* this should only fail in case of extreme resource shortage,
* need to prevent login in that case for CAPP compliance.
*/
- pam_syslog(pamh, LOG_CRIT, "audit_open() failed: %s",
- strerror(errno));
+ pam_syslog(pamh, LOG_CRIT, "audit_open() failed: %m");
return PAM_SYSTEM_ERR;
}