summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog12
-rw-r--r--Makefile.am3
-rw-r--r--configure.in3
-rw-r--r--doc/Makefile.am21
-rw-r--r--doc/specs/.cvsignore2
-rw-r--r--doc/specs/Makefile.am23
-rw-r--r--doc/specs/formatter/Makefile16
-rw-r--r--doc/specs/parse.lex (renamed from doc/specs/formatter/parse.lex)0
-rw-r--r--doc/specs/parse.y (renamed from doc/specs/formatter/parse.y)9
9 files changed, 57 insertions, 32 deletions
diff --git a/ChangeLog b/ChangeLog
index 2e74e940..f73fc84f 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,15 @@
+2005-09-26 Thorsten Kukuk <kukuk@suse.de>
+
+ * configure.in: Add doc/specs/Makefile.
+ * Makefile.am: Add releasedocs rule.
+ * doc/Makefile.am: Add specs subdir, remove files from specs
+ directory, add rfc86.0.txt to releasedocs.
+ * doc/specs/Makefile.am: New file.
+ * doc/specs/formatter/parse.y: move from here ...
+ * doc/specs/parse.y: ... here.
+ * doc/specs/formatter/parse.lex: move from here ...
+ * doc/specs/parse.lex: ... here.
+
2005-09-23 Tomas Mraz <t8m@centrum.cz>
* modules/pam_access/pam_access.c (from_match): Support NULL from.
diff --git a/Makefile.am b/Makefile.am
index 361ca041..b62e26a6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,3 +14,6 @@ EXTRA_DIST = config.rpath mkinstalldirs pgp.keys.asc CHANGELOG \
Copyright $(M4_FILES)
ACLOCAL_AMFLAGS = -I m4
+
+releasedocs:
+ make -C doc releasedocs
diff --git a/configure.in b/configure.in
index 1c8d7dd0..2a13a83b 100644
--- a/configure.in
+++ b/configure.in
@@ -396,4 +396,5 @@ AC_OUTPUT(Makefile libpam/Makefile libpamc/Makefile libpamc/test/Makefile \
modules/pam_time/Makefile modules/pam_umask/Makefile \
modules/pam_unix/Makefile modules/pam_userdb/Makefile \
modules/pam_warn/Makefile modules/pam_wheel/Makefile \
- modules/pam_xauth/Makefile doc/Makefile examples/Makefile)
+ modules/pam_xauth/Makefile doc/Makefile doc/specs/Makefile \
+ examples/Makefile)
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 81b24b4c..a2967461 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -2,6 +2,8 @@
# Copyright (c) 2005 Thorsten Kukuk <kukuk@suse.de>
#
+SUBDIRS = specs
+
FILES=pam pam_appl pam_modules
FSRCS=$(srcdir)/pam_appl.sgml $(srcdir)/pam_modules.sgml
@@ -13,8 +15,7 @@ PDFFILES=pdf/pam.pdf pdf/pam_appl.pdf pdf/pam_modules.pdf
MODULES=$(shell ls $(srcdir)/modules/*.sgml)
CLEANFILES = *~ */*~ $(TEXTS) $(PSFILES) $(PDFFILES) html/pam*.html \
- ps/missfont.log MODULES-SGML pam.sgml \
- specs/draft-morgan-pam-current.txt
+ ps/missfont.log MODULES-SGML pam.sgml
EXTRA_DIST = $(FSRCS) CREDITS NOTES figs/pam_orient.txt pdf/README \
ps/README html/index.html txts/README man/template-man $(MANS) \
@@ -139,14 +140,12 @@ if HAVE_SGML2HTML
done
endif
-spec: specs/draft-morgan-pam.raw
- cd specs/formatter && $(MAKE)
- specs/formatter/padout < specs/draft-morgan-pam.raw > specs/draft-morgan-pam-current.txt
-
-releasedocs: all spec
- tar zvfc Linux-PAM-$(VERSION)-docs.tar.gz \
+releasedocs: all
+ tar zvfc ../Linux-PAM-$(VERSION)-docs.tar.gz \
--exclude CVS --exclude .cvsignore --exclude '.#*' \
- html ps txts pdf specs/draft-morgan-pam-current.txt
- tar jvfc Linux-PAM-$(VERSION)-docs.tar.bz2 \
+ --exclude README html ps txts pdf \
+ specs/draft-morgan-pam-current.txt specs/rfc86.0.txt
+ tar jvfc ../Linux-PAM-$(VERSION)-docs.tar.bz2 \
--exclude CVS --exclude .cvsignore --exclude '.#*' \
- html ps txts pdf specs/draft-morgan-pam-current.txt
+ --exclude README html ps txts pdf \
+ specs/draft-morgan-pam-current.txt specs/rfc86.0.txt
diff --git a/doc/specs/.cvsignore b/doc/specs/.cvsignore
index bac7934f..33cd58dc 100644
--- a/doc/specs/.cvsignore
+++ b/doc/specs/.cvsignore
@@ -1,3 +1,5 @@
draft-morgan-pam-*.txt
Makefile
Makefile.in
+parse.c
+lex.yy.c
diff --git a/doc/specs/Makefile.am b/doc/specs/Makefile.am
new file mode 100644
index 00000000..749f0ba7
--- /dev/null
+++ b/doc/specs/Makefile.am
@@ -0,0 +1,23 @@
+#
+# Copyright (c) 2005 Thorsten Kukuk <kukuk@suse.de>
+#
+
+CLEANFILES = draft-morgan-pam-current.txt *~
+
+EXTRA_DIST = draft-morgan-pam.raw std-agent-id.raw rfc86.0.txt lex.yy.c
+
+all: padout spec
+
+spec: draft-morgan-pam.raw
+ ./padout < draft-morgan-pam.raw > draft-morgan-pam-current.txt
+
+noinst_PROGRAMS = padout
+
+padout_SOURCES = parse.y parse.lex
+
+padout_LDADD = @LEXLIB@
+
+parse.c: lex.yy.c
+
+lex.yy.c: parse.lex
+ $(LEX) parse.lex
diff --git a/doc/specs/formatter/Makefile b/doc/specs/formatter/Makefile
deleted file mode 100644
index d73258d7..00000000
--- a/doc/specs/formatter/Makefile
+++ /dev/null
@@ -1,16 +0,0 @@
-LIBS=-lfl
-
-padout: parse.tab.o
- $(CC) -o padout parse.tab.o $(LIBS)
-
-parse.tab.o: parse.tab.c lex.yy.c
- $(CC) -c parse.tab.c
-
-parse.tab.c: parse.y
- bison parse.y
-
-lex.yy.c: parse.lex
- flex parse.lex
-
-clean:
- rm -f parse.tab.o parse.tab.c lex.yy.c padout *~ core
diff --git a/doc/specs/formatter/parse.lex b/doc/specs/parse.lex
index 1d5c898e..1d5c898e 100644
--- a/doc/specs/formatter/parse.lex
+++ b/doc/specs/parse.lex
diff --git a/doc/specs/formatter/parse.y b/doc/specs/parse.y
index 6da47d17..9d0e2534 100644
--- a/doc/specs/formatter/parse.y
+++ b/doc/specs/parse.y
@@ -170,7 +170,7 @@ typedef struct node_s {
node_t label_root = NULL;
node_t counter_root = NULL;
-const char *find_key(node_t root, const char *key)
+static const char *find_key(node_t root, const char *key)
{
while (root) {
int cmp = strcmp(key, root->key);
@@ -186,7 +186,7 @@ const char *find_key(node_t root, const char *key)
return NULL;
}
-node_t set_key(node_t root, const char *key, const char *value)
+static node_t set_key(node_t root, const char *key, const char *value)
{
if (root) {
int cmp = strcmp(key, root->key);
@@ -287,7 +287,8 @@ char *new_counter(const char *key)
return new;
}
-main()
+int
+main(void)
{
- yyparse();
+ return yyparse();
}