summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGELOG2
-rw-r--r--modules/pam_cracklib/Makefile5
-rw-r--r--modules/pam_cracklib/pam_cracklib.c5
3 files changed, 7 insertions, 5 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 5586f345..ca31df7a 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -47,6 +47,8 @@ libpam. Prior versions were buggy - see bugfix for Bug 129775.
** WARNING **
+* pam_cracklib needs to be linked with -lcrypt (old password checking)
+ (Bug 131601 - agmorgan)
* fixes for static library builds and also the examples when linked
with the debugging build of the libraries. (Bug 131783 - agmorgan)
* fixed URL for original RFC to a cached kernel.org file. (Bug 131503
diff --git a/modules/pam_cracklib/Makefile b/modules/pam_cracklib/Makefile
index c279857c..5f6371ef 100644
--- a/modules/pam_cracklib/Makefile
+++ b/modules/pam_cracklib/Makefile
@@ -5,7 +5,7 @@
# Linux-PAM. You should not modify this Makefile (unless you know
# what you are doing!).
#
-# Created by Andrew Morgan <morgan@linux.kernel.org> 2000/10/08
+# Created by Andrew Morgan <morgan@kernel.org> 2000/10/08
#
include ../../Make.Rules
@@ -18,8 +18,9 @@ MODULE_SIMPLE_EXTRALIBS=-lcrack
# These two should really be provided by ../../pam_aconf.h
CFLAGS+=-DCRACKLIB_DICTPATH=\"$(CRACKLIB_DICTPATH)\"
+
ifeq ($(HAVE_LIBCRYPT),yes)
- CFLAGS+=-DNEED_CRYPT_HEADER
+ MODULE_SIMPLE_EXTRALIBS += -lcrypt
endif
endif
diff --git a/modules/pam_cracklib/pam_cracklib.c b/modules/pam_cracklib/pam_cracklib.c
index c79d4e76..07725db7 100644
--- a/modules/pam_cracklib/pam_cracklib.c
+++ b/modules/pam_cracklib/pam_cracklib.c
@@ -29,11 +29,10 @@
* S.A.G. in the section on the cracklib module.
*/
-#define _GNU_SOURCE
-#define _BSD_SOURCE
+#include <security/_pam_aconf.h>
#include <stdio.h>
-#ifdef NEED_CRYPT_HEADER
+#ifdef HAVE_CRYPT_H
# include <crypt.h>
#endif
#include <unistd.h>