summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches-applied/hurd_no_setfsuid2
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index e47407a8..08dfcebf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -91,6 +91,9 @@ pam (1.0.1-1) UNRELEASED; urgency=low
other manpages. Closes: #470137.
* Add debian/README.source documenting that this package uses quilt.
* Bump Standards-Version to 3.8.0.
+ * Fix a bug in the uid-restoring code in the hurd_no_setfsuid patch; thanks
+ to Tomas Mraz <tmraz@redhat.com> for indirectly bringing this to my
+ attention
-- Steve Langasek <vorlon@debian.org> Tue, 22 Jul 2008 10:55:45 -0700
diff --git a/debian/patches-applied/hurd_no_setfsuid b/debian/patches-applied/hurd_no_setfsuid
index 71ae5d77..76501432 100644
--- a/debian/patches-applied/hurd_no_setfsuid
+++ b/debian/patches-applied/hurd_no_setfsuid
@@ -55,7 +55,7 @@ Index: Linux-PAM/modules/pam_xauth/pam_xauth.c
+ if (uid == pwd->pw_uid)
+ setreuid(uid, euid);
+ else {
-+ if (setreuid(-1, 0) == -1)
++ if (setreuid(-1, 0) != -1)
+ setreuid(uid, -1);
+ setreuid(-1, euid);
+ }