summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog7
-rw-r--r--configure.in8
-rw-r--r--doc/specs/Makefile.am4
3 files changed, 17 insertions, 2 deletions
diff --git a/ChangeLog b/ChangeLog
index 6fbdb4e0..df2b0820 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,10 @@
+2010-08-26 Thorsten Kukuk <kukuk@thkukuk.de>
+
+ * doc/specs/Makefile.am: Use CC_FOR_BUILD as compiler (cross
+ compile support).
+ * configure.in: Check for host compiler if cross compiling.
+ Bug #2315432, debian#284854#42.
+
2010-08-17 Thorsten Kukuk <kukuk@thkukuk.de>
* modules/pam_unix/pam_unix_passwd.c: Implement minlen option.
diff --git a/configure.in b/configure.in
index 87bd5680..cb827112 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
dnl Process this file with autoconf to produce a configure script.
AC_INIT
AC_CONFIG_SRCDIR([conf/pam_conv1/pam_conv_y.y])
-AM_INIT_AUTOMAKE("Linux-PAM", 1.1.1)
+AM_INIT_AUTOMAKE("Linux-PAM", 1.1.1.91)
AC_PREREQ(2.61)
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_MACRO_DIR([m4])
@@ -86,6 +86,12 @@ AM_PROG_CC_C_O
PAM_LD_AS_NEEDED
PAM_LD_O1
+if test x"$cross_compiling" = xyes; then
+ AC_CHECK_PROGS(CC_FOR_BUILD, gcc cc)
+else
+ CC_FOR_BUILD="$CC"
+fi
+
dnl Largefile support
AC_SYS_LARGEFILE
diff --git a/doc/specs/Makefile.am b/doc/specs/Makefile.am
index 595c09bf..d92ddd38 100644
--- a/doc/specs/Makefile.am
+++ b/doc/specs/Makefile.am
@@ -1,5 +1,5 @@
#
-# Copyright (c) 2005, 2006 Thorsten Kukuk <kukuk@suse.de>
+# Copyright (c) 2005, 2006, 2010 Thorsten Kukuk <kukuk@suse.de>
#
CLEANFILES = draft-morgan-pam-current.txt *~
@@ -11,6 +11,8 @@ draft-morgan-pam-current.txt: padout draft-morgan-pam.raw
AM_YFLAGS = -d
+CC = @CC_FOR_BUILD@
+
BUILT_SOURCES = parse_y.h
noinst_PROGRAMS = padout