summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGELOG2
-rwxr-xr-xconfigure10
-rw-r--r--configure.in4
-rw-r--r--libpam/pam_strerror.c14
4 files changed, 2 insertions, 28 deletions
diff --git a/CHANGELOG b/CHANGELOG
index a62e370a..8583bf99 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -64,6 +64,8 @@ BerliOS Bugs are marked with (BerliOS #XXXX).
patches!
* pam_umask: New module for setting umask from GECOS field, /etc/login.defs
or /etc/default/login (kukuk)
+* configure/pam_strerror: Remove old ugly-hack option for pam_strerror
+ interface change (kukuk)
0.80: Wed Jul 13 13:23:20 CEST 2005
* pam_tally: test for NULL data before dereferencing them (t8m)
diff --git a/configure b/configure
index 5e36e210..5e73e47a 100755
--- a/configure
+++ b/configure
@@ -854,7 +854,6 @@ Optional Features:
--enable-docdir=<path to store documentation in - /usr/share/doc/pam>
--enable-mandir=<path to store manuals in - /usr/share/man>
--enable-pamlocking configure libpam to observe a global authentication lock
- --enable-uglyhack configure libpam to try to honor old pam_strerror syntax
--enable-read-both-confs read both /etc/pam.d and /etc/pam.conf files
--enable-static-libpam build a libpam.a library
--disable-dynamic-libpam do not build a shared libpam library
@@ -2882,15 +2881,6 @@ else
fi;
-# Check whether --enable-uglyhack or --disable-uglyhack was given.
-if test "${enable_uglyhack+set}" = set; then
- enableval="$enable_uglyhack"
- cat >>confdefs.h <<\_ACEOF
-#define UGLY_HACK_FOR_PRIOR_BEHAVIOR_SUPPORT 1
-_ACEOF
-
-fi;
-
# Check whether --enable-read-both-confs or --disable-read-both-confs was given.
if test "${enable_read_both_confs+set}" = set; then
enableval="$enable_read_both_confs"
diff --git a/configure.in b/configure.in
index ff1bf311..9012b30a 100644
--- a/configure.in
+++ b/configure.in
@@ -131,10 +131,6 @@ AC_ARG_ENABLE(pamlocking,
WITH_PAMLOCKING=yes ; AC_DEFINE(PAM_LOCKING) , WITH_PAMLOCKING=no)
AC_SUBST(WITH_PAMLOCKING)
-AC_ARG_ENABLE(uglyhack,
-[ --enable-uglyhack configure libpam to try to honor old pam_strerror syntax],
- AC_DEFINE(UGLY_HACK_FOR_PRIOR_BEHAVIOR_SUPPORT))
-
AC_ARG_ENABLE(read-both-confs,
[ --enable-read-both-confs read both /etc/pam.d and /etc/pam.conf files],
AC_DEFINE(PAM_READ_BOTH_CONFS))
diff --git a/libpam/pam_strerror.c b/libpam/pam_strerror.c
index b2c6775a..3bec2a6d 100644
--- a/libpam/pam_strerror.c
+++ b/libpam/pam_strerror.c
@@ -8,20 +8,6 @@
const char *pam_strerror(pam_handle_t *pamh, int errnum)
{
-#ifdef UGLY_HACK_FOR_PRIOR_BEHAVIOR_SUPPORT /* will be removed from v 1.0 */
-
- int possible_error;
-
- possible_error = (int) pamh;
- if (!(possible_error >= 0 && possible_error <= PAM_BAD_ITEM)) {
- possible_error = errnum;
- }
-
-/* mask standard behavior to use possible_error variable. */
-#define errnum possible_error
-
-#endif /* UGLY_HACK_FOR_PRIOR_BEHAVIOR_SUPPORT */
-
switch (errnum) {
case PAM_SUCCESS:
return "Success";