summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog8
-rw-r--r--configure.in7
-rw-r--r--modules/pam_lastlog/pam_lastlog.c2
3 files changed, 13 insertions, 4 deletions
diff --git a/ChangeLog b/ChangeLog
index d5b2ee96..2a35d48b 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,11 @@
+2006-02-22 Thorsten Kukuk <kukuk@thkukuk.de>
+
+ * configure.in: Fix check for incomplete libaudit installations
+ (Patch from Ruediger Oertel <ro@suse.de>)
+
+ * modules/pam_lastlog/pam_lastlog.c (last_login_write): Initialize
+ correct last_login field [#1427401]
+
2006-02-17 Thorsten Kukuk <kukuk@thkukuk.de>
* doc/man/Makefile.am: Add new manual pages.
diff --git a/configure.in b/configure.in
index 10d65b21..6959c852 100644
--- a/configure.in
+++ b/configure.in
@@ -307,10 +307,11 @@ AC_SUBST(LIBCRACK)
AM_CONDITIONAL([HAVE_LIBCRACK], [test ! -z "$LIBCRACK"])
dnl Look for Linux Auditing library - see documentation
-AC_CHECK_HEADER([libaudit.h])
-AC_CHECK_LIB(audit, audit_log_user_message, LIBAUDIT=-laudit, LIBAUDIT="")
+AC_CHECK_HEADER([libaudit.h],
+ [AC_CHECK_LIB(audit, audit_log_user_message, LIBAUDIT=-laudit, LIBAUDIT="")]
+)
AC_SUBST(LIBAUDIT)
-if test ! -z "$LIBAUDIT" ; then
+if test ! -z "$LIBAUDIT" -a "ac_cv_header_libaudit_h" != "no" ; then
AC_DEFINE([HAVE_LIBAUDIT], 1, [Defined if audit support should be compiled in])
fi
diff --git a/modules/pam_lastlog/pam_lastlog.c b/modules/pam_lastlog/pam_lastlog.c
index 24a13ef6..7e635335 100644
--- a/modules/pam_lastlog/pam_lastlog.c
+++ b/modules/pam_lastlog/pam_lastlog.c
@@ -274,7 +274,7 @@ last_login_write(pam_handle_t *pamh, int announce, int last_fd,
terminal_line = get_tty(pamh);
/* copy to last_login */
- last_login.ll_host[0] = '\0';
+ last_login.ll_line[0] = '\0';
strncat(last_login.ll_line, terminal_line, sizeof(last_login.ll_line)-1);
terminal_line = NULL;