summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog7
-rw-r--r--Make.xml.rules22
-rw-r--r--modules/pam_exec/Makefile.am8
-rw-r--r--modules/pam_exec/pam_exec.810
-rw-r--r--modules/pam_exec/pam_exec.8.xml25
5 files changed, 42 insertions, 30 deletions
diff --git a/ChangeLog b/ChangeLog
index 1761ff7b..f7f1f49b 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,10 @@
+2006-01-30 Thorsten Kukuk <kukuk@thkukuk.de>
+
+ * modules/pam_exec/pam_exec.8.xml: Fix syntax of Return Value section.
+ * modules/pam_exec/Makefile.am: Include Make.xml.rules.
+
+ * Make.xml.rules: New.
+
2006-01-27 Thorsten Kukuk <kukuk@thkukuk.de>
* configure.in: Prefer libdb over libndbm, fix check for
diff --git a/Make.xml.rules b/Make.xml.rules
new file mode 100644
index 00000000..f6512aae
--- /dev/null
+++ b/Make.xml.rules
@@ -0,0 +1,22 @@
+#
+# Copyright (c) 2006 Thorsten Kukuk <kukuk@thkukuk.de>
+#
+
+%.1: %.1.xml
+ $(XMLLINT) --nonet --xinclude --postvalid --noout $<
+ $(XSLTPROC) --nonet http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
+
+%.3: %.3.xml
+ $(XMLLINT) --nonet --xinclude --postvalid --noout $<
+ $(XSLTPROC) --nonet http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
+
+%.5: %.5.xml
+ $(XMLLINT) --nonet --xinclude --postvalid --noout $<
+ $(XSLTPROC) --nonet http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
+
+%.8: %.8.xml
+ $(XMLLINT) --nonet --xinclude --postvalid --noout $<
+ $(XSLTPROC) --nonet http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
+
+#CLEANFILES += $(man_MANS)
+
diff --git a/modules/pam_exec/Makefile.am b/modules/pam_exec/Makefile.am
index e67013d1..e7ecd591 100644
--- a/modules/pam_exec/Makefile.am
+++ b/modules/pam_exec/Makefile.am
@@ -22,12 +22,6 @@ endif
securelib_LTLIBRARIES = pam_exec.la
if ENABLE_REGENERATE_MAN
-
-pam_exec.8: pam_exec.8.xml
- $(XMLLINT) --nonet --xinclude --postvalid --noout $<
- $(XSLTPROC) --nonet http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
-
-#CLEANFILES += $(man_MANS)
-
+-include $(top_srcdir)/Make.xml.rules
endif
diff --git a/modules/pam_exec/pam_exec.8 b/modules/pam_exec/pam_exec.8
index 6ecd2dc9..96761ac6 100644
--- a/modules/pam_exec/pam_exec.8
+++ b/modules/pam_exec/pam_exec.8
@@ -2,7 +2,7 @@
.\" It was generated using the DocBook XSL Stylesheets (version 1.69.1).
.\" Instead of manually editing it, you probably should edit the DocBook XML
.\" source for it and then use the DocBook XSL Stylesheets to regenerate it.
-.TH "PAM_EXEC" "8" "01/24/2006" "Linux\-PAM Manual" "Linux\-PAM Manual"
+.TH "PAM_EXEC" "8" "01/30/2006" "Linux\-PAM Manual" "Linux\-PAM Manual"
.\" disable hyphenation
.nh
.\" disable justification (adjust text to left margin only)
@@ -39,16 +39,16 @@ are supported.
.SH "RETURN VALUES"
.PP
.TP
-\fBPAM_SUCCESS\fR
+PAM_SUCCESS
The external command runs successfull.
.TP
-\fBPAM_SERVICE_ERR\fR
+PAM_SERVICE_ERR
No argument or a wrong number of arguments were given.
.TP
-\fBPAM_SYSTEM_ERR\fR
+PAM_SYSTEM_ERR
A system error occured or the command to execute failed.
.TP
-\fBPAM_IGNORE\fR
+PAM_IGNORE
\fBpam_setcred\fR
was called, which does not execute the command.
.SH "EXAMPLES"
diff --git a/modules/pam_exec/pam_exec.8.xml b/modules/pam_exec/pam_exec.8.xml
index 112f76cd..3b681cf2 100644
--- a/modules/pam_exec/pam_exec.8.xml
+++ b/modules/pam_exec/pam_exec.8.xml
@@ -109,9 +109,7 @@
<variablelist>
<varlistentry>
- <term>
- <option>PAM_SUCCESS</option>
- </term>
+ <term>PAM_SUCCESS</term>
<listitem>
<para>
The external command runs successfull.
@@ -120,9 +118,7 @@
</varlistentry>
<varlistentry>
- <term>
- <option>PAM_SERVICE_ERR</option>
- </term>
+ <term>PAM_SERVICE_ERR</term>
<listitem>
<para>
No argument or a wrong number of arguments were given.
@@ -131,9 +127,7 @@
</varlistentry>
<varlistentry>
- <term>
- <option>PAM_SYSTEM_ERR</option>
- </term>
+ <term>PAM_SYSTEM_ERR</term>
<listitem>
<para>
A system error occured or the command to execute failed.
@@ -142,9 +136,7 @@
</varlistentry>
<varlistentry>
- <term>
- <option>PAM_IGNORE</option>
- </term>
+ <term>PAM_IGNORE</term>
<listitem>
<para>
<function>pam_setcred</function> was called, which
@@ -176,16 +168,13 @@
<title>See Also</title>
<para>
<citerefentry>
- <refentrytitle>pam.conf</refentrytitle>
- <manvolnum>5</manvolnum>
+ <refentrytitle>pam.conf</refentrytitle><manvolnum>5</manvolnum>
</citerefentry>,
<citerefentry>
- <refentrytitle>pam.d</refentrytitle>
- <manvolnum>8</manvolnum>
+ <refentrytitle>pam.d</refentrytitle><manvolnum>8</manvolnum>
</citerefentry>,
<citerefentry>
- <refentrytitle>pam</refentrytitle>
- <manvolnum>8</manvolnum>
+ <refentrytitle>pam</refentrytitle><manvolnum>8</manvolnum>
</citerefentry>
</para>
</refsect1>