summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches-applied/series2
-rw-r--r--debian/patches-applied/update-motd98
-rw-r--r--debian/po/eu.po29
4 files changed, 127 insertions, 10 deletions
diff --git a/debian/changelog b/debian/changelog
index e48b862b..8666f373 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,8 @@ pam (1.0.1-10) UNRELEASED; urgency=low
- Finnish, thanks to Esko Arajärvi <edu@iki.fi> (closes: #520785)
- Russian, thanks to Yuri Kozlov <yuray@komyakino.ru> (closes: #521874)
- German, thanks to Sven Joachim <svenjoac@gmx.de> (closes: #521530)
+ - Basque, thanks to Piarres Beobide <pi+debian@beobide.net>
+ (closes: #524285)
[ Kees Cook ]
* Add debian/patches/pam_1.0.4_mindays: backport upstream 1.0.4 fixes
@@ -18,7 +20,11 @@ pam (1.0.1-10) UNRELEASED; urgency=low
* pam_mail-fix-quiet: patch from Andreas Henriksson
applied upstream to fix quiet option of pam_mail, Closes: #439268
- -- Sam Hartman <hartmans@debian.org> Sat, 30 May 2009 17:26:14 -0400
+ [ Dustin Kirkland ]
+ * debian/patches/update-motd: run the update-motd scripts in pam_motd;
+ render update-motd obsolete, LP: #399071
+
+ -- Steve Langasek <vorlon@debian.org> Sun, 22 Mar 2009 20:36:14 -0700
pam (1.0.1-9) unstable; urgency=low
diff --git a/debian/patches-applied/series b/debian/patches-applied/series
index 1b3bddae..3e763c96 100644
--- a/debian/patches-applied/series
+++ b/debian/patches-applied/series
@@ -23,4 +23,6 @@ pam_unix-chkpwd-wait
autoconf.patch
dont_freeze_password_chain -p0
pam_1.0.4_mindays
+update-motd
pam_mail-fix-quiet
+
diff --git a/debian/patches-applied/update-motd b/debian/patches-applied/update-motd
new file mode 100644
index 00000000..8c7b675a
--- /dev/null
+++ b/debian/patches-applied/update-motd
@@ -0,0 +1,98 @@
+Patch for Ubuntu bug #399071
+
+Provide a more dynamic MOTD, based on the short-lived update-motd project.
+
+Authors: Dustin Kirkland <kirkland@canonical.com>
+
+Upstream status: not yet submitted
+
+Index: pam-1.0.1/modules/pam_motd/pam_motd.c
+===================================================================
+--- pam-1.0.1.orig/modules/pam_motd/pam_motd.c
++++ pam-1.0.1/modules/pam_motd/pam_motd.c
+@@ -48,14 +48,38 @@
+
+ static char default_motd[] = DEFAULT_MOTD;
+
++static void display_file(pam_handle_t *pamh, const char *motd_path)
++{
++ int fd;
++ char *mtmp = NULL;
++ while ((fd = open(motd_path, O_RDONLY, 0)) >= 0) {
++ struct stat st;
++ /* fill in message buffer with contents of motd */
++ if ((fstat(fd, &st) < 0) || !st.st_size || st.st_size > 0x10000)
++ break;
++ if (!(mtmp = malloc(st.st_size+1)))
++ break;
++ if (pam_modutil_read(fd, mtmp, st.st_size) != st.st_size)
++ break;
++ if (mtmp[st.st_size-1] == '\n')
++ mtmp[st.st_size-1] = '\0';
++ else
++ mtmp[st.st_size] = '\0';
++ pam_info (pamh, "%s", mtmp);
++ break;
++ }
++ _pam_drop (mtmp);
++ if (fd >= 0)
++ close(fd);
++}
++
+ PAM_EXTERN
+ int pam_sm_open_session(pam_handle_t *pamh, int flags,
+ int argc, const char **argv)
+ {
+ int retval = PAM_IGNORE;
+- int fd;
+ const char *motd_path = NULL;
+- char *mtmp = NULL;
++ struct stat st;
+
+ if (flags & PAM_SILENT) {
+ return retval;
+@@ -80,34 +104,19 @@
+ if (motd_path == NULL)
+ motd_path = default_motd;
+
+- while ((fd = open(motd_path, O_RDONLY, 0)) >= 0) {
+- struct stat st;
+-
+- /* fill in message buffer with contents of motd */
+- if ((fstat(fd, &st) < 0) || !st.st_size || st.st_size > 0x10000)
+- break;
+-
+- if (!(mtmp = malloc(st.st_size+1)))
+- break;
+-
+- if (pam_modutil_read(fd, mtmp, st.st_size) != st.st_size)
+- break;
+-
+- if (mtmp[st.st_size-1] == '\n')
+- mtmp[st.st_size-1] = '\0';
+- else
+- mtmp[st.st_size] = '\0';
+-
+- pam_info (pamh, "%s", mtmp);
+- break;
++ /* Run the update-motd dynamic motd scripts, outputting to /var/run/motd.
++ If /etc/motd -> /var/run/motd, the displayed MOTD will be dynamic.
++ Otherwise, the admin can force a static MOTD by breaking that symlink
++ and publishing into an /etc/motd text file. */
++ if ((stat("/etc/update-motd.d", &st) == 0) && S_ISDIR(st.st_mode)) {
++ if (!system("run-parts --lsbsysinit /etc/update-motd.d > /var/run/motd.new"))
++ rename("/var/run/motd.new", "/var/run/motd");
+ }
+
+- _pam_drop (mtmp);
+-
+- if (fd >= 0)
+- close(fd);
++ /* Display the updated motd */
++ display_file(pamh, motd_path);
+
+- return retval;
++ return retval;
+ }
+
+
diff --git a/debian/po/eu.po b/debian/po/eu.po
index 47e04e4d..9fd1369b 100644
--- a/debian/po/eu.po
+++ b/debian/po/eu.po
@@ -11,8 +11,8 @@ msgstr ""
"Report-Msgid-Bugs-To: pam@packages.debian.org\n"
"POT-Creation-Date: 2009-02-28 13:06-0800\n"
"PO-Revision-Date: 2009-01-02 12:30+0100\n"
-"Last-Translator: Iñaki Larrañaga Murgoitio <dooteo@euskalgnu.org>\n"
-"Language-Team: Basque <itzulpena@euskalgnu.org>\n"
+"Last-Translator: Piarres Beobide <pi@beobide.net>\n"
+"Language-Team: debian-eu <debian-l10n-eu@lists.debian.org>\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
@@ -64,7 +64,7 @@ msgstr ""
#. Description
#: ../libpam0g.templates:3001
msgid "Failure restarting some services for PAM upgrade"
-msgstr "Huts egin du zenbait zerbitzu berrabiaraztean PAM bertsio-berritzeko."
+msgstr "Huts PAM bertsio-berritzeko zenbait zerbitzu berrabiaraztean"
#. Type: error
#. Description
@@ -89,7 +89,7 @@ msgstr ""
#. Description
#: ../libpam-runtime.templates:1001
msgid "PAM profiles to enable:"
-msgstr ""
+msgstr "Gaitu behar diren PAM profilak:"
#. Type: multiselect
#. Description
@@ -100,6 +100,9 @@ msgid ""
"allowing configuration of additional actions to take when starting user "
"sessions."
msgstr ""
+"Autentifikazio modulu txertagarriak (PAM) ezartzen du zein autentifikazio, "
+"autorizazio eta psahitz aldaketa kudeatzen diren sisteman, baita erabiltzaile "
+"saioak hastekoan ekintza gehigarrien konfigurazioaren onarpena du."
#. Type: multiselect
#. Description
@@ -109,12 +112,15 @@ msgid ""
"adjust the behavior of all PAM-using applications on the system. Please "
"indicate which of these behaviors you wish to enable."
msgstr ""
+"Zenbait PAM modulu paketek sisteman PAM erbailtzen duten aplikazioak "
+"automatikoki doitzeko erabili daitezkeen profilak ekartzen dituzte. Mesedez "
+"profil hauetako zein gaitu nahi duzun."
#. Type: error
#. Description
#: ../libpam-runtime.templates:2001
msgid "Incompatible PAM profiles selected."
-msgstr ""
+msgstr "PAM profil bateraezinak hautatuak."
#. Type: error
#. Description
@@ -122,19 +128,19 @@ msgstr ""
#. PAM profile names.
#: ../libpam-runtime.templates:2001
msgid "The following PAM profiles cannot be used together:"
-msgstr ""
+msgstr "Hurrengo PAM profilak ezin dira elkarrekin erabili:"
#. Type: error
#. Description
#: ../libpam-runtime.templates:2001
msgid "Please select a different set of modules to enable."
-msgstr ""
+msgstr "Mesedez hautatu gaitzeko beste modulu bilduma bat."
#. Type: boolean
#. Description
#: ../libpam-runtime.templates:3001
msgid "Override local changes to /etc/pam.d/common-*?"
-msgstr ""
+msgstr "Gainidatzi aldaketa lokalak /etc/pam.d/common-* -era?"
#. Type: boolean
#. Description
@@ -146,6 +152,11 @@ msgid ""
"decline this option, you will need to manage your system's authentication "
"configuration by hand."
msgstr ""
+"/etc/pam.d/common-{auth,account,password,session} fitxategietako bat edo "
+"gehiago lokalki eraldatua izan da. Mesedez zehaztu aldaketa horiek "
+"sistemak-hornitutako konfigurazioaz gainidatzi behar diren ala ez. Aukera "
+"hau baztertzea hautatzen baduzu sistemaren autentifikazio konfigurazioa "
+"eskuz kudeatu behar duzu."
#. Type: error
#. Description
@@ -153,7 +164,7 @@ msgstr ""
msgid "xscreensaver and xlockmore must be restarted before upgrading"
msgstr ""
"xscreensaver eta xlockmore berrabiarazi egin behar dira bertsio-berritu "
-"aurretik."
+"aurretik"
#. Type: error
#. Description