summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog4
-rw-r--r--xtests/tst-pam_dispatch4.c3
-rw-r--r--xtests/tst-pam_dispatch4.pamd6
3 files changed, 8 insertions, 5 deletions
diff --git a/ChangeLog b/ChangeLog
index a7284ca5..14ac26e3 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2007-10-18 Tomas Mraz <t8m@centrum.cz>
+ * xtests/tst-pam_dispatch4.c: Fix comment about the test.
+ * xtests/tst-pam_dispatch4.pamd: Improve the testcase.
+
2007-10-12 Thorsten Kukuk <kukuk@thkukuk.de>
* xtests/Makefile.am: Add tst-pam_dispatch5 sources
diff --git a/xtests/tst-pam_dispatch4.c b/xtests/tst-pam_dispatch4.c
index 745e9cfc..a4db8a88 100644
--- a/xtests/tst-pam_dispatch4.c
+++ b/xtests/tst-pam_dispatch4.c
@@ -46,8 +46,7 @@ static struct pam_conv conv = {
};
-/* Check that errors of optional modules are ignored and that
- required modules after a sufficient one are not executed. */
+/* Check that jumps are processed correctly. */
int
main(int argc, char *argv[])
diff --git a/xtests/tst-pam_dispatch4.pamd b/xtests/tst-pam_dispatch4.pamd
index 7c08372b..ac995add 100644
--- a/xtests/tst-pam_dispatch4.pamd
+++ b/xtests/tst-pam_dispatch4.pamd
@@ -1,8 +1,8 @@
#%PAM-1.0
-# We jump to pam_permit.so, should pass
+# We jump to end of the stack with previous pam_permit.so, should pass
+auth required pam_permit.so
auth [success=1 default=ignore] pam_debug.so auth=success
auth required pam_deny.so
-auth required pam_permit.so
-# We jump to a non-existing slot, fail, but don't seg.fault
+# We jump to end of the stack without any module in OK state, should fail
account [success=1 default=ignore] pam_debug.so account=success
account required pam_deny.so