summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches-applied/022_pam_unix_group_time_miscfixes19
2 files changed, 2 insertions, 19 deletions
diff --git a/debian/changelog b/debian/changelog
index b649848c..01fc400d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,6 +7,8 @@ pam (0.99.8.1-1) UNRELEASED; urgency=low
- new minclass option introduced for pam_cracklib. Closes: #454237.
- use --disable-audit, to avoid libaudit being linked in
accidentally
+ * Patch 022_pam_unix_group_time_miscfixes: partially merged upstream;
+ now is really just "pam_group_miscfixes".
* Use a pristine upstream tarball instead of repacking; requires various
changes to debian/rules and debhelper files.
* Replace the Vcs-Svn field with a Vcs-Bzr field; jumping ship from svn,
diff --git a/debian/patches-applied/022_pam_unix_group_time_miscfixes b/debian/patches-applied/022_pam_unix_group_time_miscfixes
index e96dd680..44ee8783 100644
--- a/debian/patches-applied/022_pam_unix_group_time_miscfixes
+++ b/debian/patches-applied/022_pam_unix_group_time_miscfixes
@@ -1,24 +1,5 @@
* Add support for credential reinitialization in pam_group, closes: #108697
- * By default do complete matches not substring matches for pam_time.
- You can include explicit wildcard for substring, closes: #66152
-Index: Linux-PAM/modules/pam_time/pam_time.c
-===================================================================
---- Linux-PAM/modules/pam_time/pam_time.c.orig
-+++ Linux-PAM/modules/pam_time/pam_time.c
-@@ -324,7 +324,11 @@
- return FALSE;
- }
- }
-- return ( !len );
-+ /* By this point we know that we didn't treat a * in b as a wildcard.
-+ the only way we got done with the loop is if we consumed every
-+ character in b. Thus the strings are equal if their
-+ lengths are the same otherwise not equal. */
-+ return (strlen (a) == strlen (b));
- }
-
- typedef struct {
Index: Linux-PAM/modules/pam_group/pam_group.c
===================================================================
--- Linux-PAM/modules/pam_group/pam_group.c.orig