summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog8
-rw-r--r--examples/xsh.c6
-rw-r--r--m4/ld-O1.m42
-rw-r--r--m4/ld-as-needed.m42
-rw-r--r--modules/pam_access/pam_access.812
-rw-r--r--modules/pam_namespace/Makefile.am7
-rw-r--r--modules/pam_succeed_if/pam_succeed_if.812
7 files changed, 22 insertions, 27 deletions
diff --git a/ChangeLog b/ChangeLog
index 16ba5969..748d6953 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,11 @@
+2006-08-31 Thorsten Kukuk <kukuk@thkukuk.de>
+
+ * modules/pam_namespace/Makefile.am: Don't install
+ manual page if we don't build module.
+
+ * m4/ld-as-needed.m4: Don't set LDFLAGS if check failed.
+ * m4/ld-O1: Likewise.
+
2006-08-30 Tomas Mraz <t8m@centrum.cz>
* modules/pam_access/pam_access.8.xml: All services supported.
diff --git a/examples/xsh.c b/examples/xsh.c
index 08b4af11..ef4dca0c 100644
--- a/examples/xsh.c
+++ b/examples/xsh.c
@@ -1,7 +1,3 @@
-/*
- * $Id$
- */
-
/* Andrew Morgan (morgan@kernel.org) -- an example application
* that invokes a shell, based on blank.c */
@@ -143,7 +139,7 @@ int main(int argc, char **argv)
(const char *)username);
/* this is always a really bad thing for security! */
- system("/bin/sh");
+ retcode = system("/bin/sh");
/* close a session for the user --- `0' could be PAM_SILENT
* it is possible that this pam_close_call is in another program..
diff --git a/m4/ld-O1.m4 b/m4/ld-O1.m4
index c8630740..6efd3f34 100644
--- a/m4/ld-O1.m4
+++ b/m4/ld-O1.m4
@@ -14,11 +14,11 @@ EOF
-Wl,-O1 1>&AS_MESSAGE_LOG_FD])
then
pam_cv_ld_O1=yes
+ LDFLAGS="$LDFLAGS -Wl,-O1"
else
pam_cv_ld_O1=no
fi
rm -f conftest*])
AC_SUBST(pam_cv_ld_as_needed)
- LDFLAGS="$LDFLAGS -Wl,-O1"
]
)
diff --git a/m4/ld-as-needed.m4 b/m4/ld-as-needed.m4
index cd81f91b..5ba6e0f9 100644
--- a/m4/ld-as-needed.m4
+++ b/m4/ld-as-needed.m4
@@ -14,11 +14,11 @@ EOF
-Wl,--as-needed 1>&AS_MESSAGE_LOG_FD])
then
pam_cv_ld_as_needed=yes
+ LDFLAGS="$LDFLAGS -Wl,--as-needed"
else
pam_cv_ld_as_needed=no
fi
rm -f conftest*])
AC_SUBST(pam_cv_ld_as_needed)
- LDFLAGS="$LDFLAGS -Wl,--as-needed"
]
)
diff --git a/modules/pam_access/pam_access.8 b/modules/pam_access/pam_access.8
index de86275f..b613e323 100644
--- a/modules/pam_access/pam_access.8
+++ b/modules/pam_access/pam_access.8
@@ -1,11 +1,11 @@
.\" Title: pam_access
.\" Author:
-.\" Generator: DocBook XSL Stylesheets v1.70.1 <http://docbook.sf.net/>
-.\" Date: 06/21/2006
+.\" Generator: DocBook XSL Stylesheets vsnapshot_2006\-08\-24_0226 <http://docbook.sf.net/>
+.\" Date: 08/31/2006
.\" Manual: Linux\-PAM Manual
.\" Source: Linux\-PAM Manual
.\"
-.TH "PAM_ACCESS" "8" "06/21/2006" "Linux\-PAM Manual" "Linux\-PAM Manual"
+.TH "PAM_ACCESS" "8" "08/31/2006" "Linux\-PAM Manual" "Linux\-PAM Manual"
.\" disable hyphenation
.nh
.\" disable justification (adjust text to left margin only)
@@ -46,11 +46,7 @@ This option modifies the list separator character that pam_access will recognize
will cause the default ` ' (space) and `\\t' (tab) characters to be treated as part of a list element value and `,' becomes the only list element separator. Doing this may be useful on a system with group information obtained from a Windows domain, where the default built\-in groups "Domain Users", "Domain Admins" contain a space.
.SH "MODULE SERVICES PROVIDED"
.PP
-The
-\fBauth\fR
-and
-\fBaccount\fR
-services are supported.
+All services are supported.
.SH "RETURN VALUES"
.TP 3n
PAM_SUCCESS
diff --git a/modules/pam_namespace/Makefile.am b/modules/pam_namespace/Makefile.am
index 9c7c2f73..bbcb2f70 100644
--- a/modules/pam_namespace/Makefile.am
+++ b/modules/pam_namespace/Makefile.am
@@ -1,13 +1,11 @@
#
-# Copyright (c) 2006 Red Hat, Inc.
+# Copyright (c) 2006 Red Hat, Inc.
#
CLEANFILES = *~
MAN5 = namespace.conf.5
MAN8 = pam_namespace.8
-man_MANS = $(MAN5) $(MAN8)
-
XMLS = README.xml namespace.conf.5.xml pam_namespace.8.xml
if ENABLE_REGENERATE_MAN
@@ -15,7 +13,7 @@ noinst_DATA = README
-include $(top_srcdir)/Make.xml.rules
endif
-EXTRA_DIST = README namespace.conf namespace.init $(man_MANS) $(XMLS) tst-pam_namespace
+EXTRA_DIST = README namespace.conf namespace.init $(MAN5) $(MAN8) $(XMLS) tst-pam_namespace
noinst_HEADERS = md5.h
@@ -37,4 +35,5 @@ pam_namespace_la_SOURCES = pam_namespace.c pam_namespace.h md5.c md5.h
secureconf_DATA = namespace.conf
secureconf_SCRIPTS = namespace.init
TESTS = tst-pam_namespace
+man_MANS = $(MAN5) $(MAN8)
endif
diff --git a/modules/pam_succeed_if/pam_succeed_if.8 b/modules/pam_succeed_if/pam_succeed_if.8
index c94c5f43..30af456c 100644
--- a/modules/pam_succeed_if/pam_succeed_if.8
+++ b/modules/pam_succeed_if/pam_succeed_if.8
@@ -1,11 +1,11 @@
.\" Title: pam_succeed_if
.\" Author:
-.\" Generator: DocBook XSL Stylesheets v1.70.1 <http://docbook.sf.net/>
-.\" Date: 08/05/2006
+.\" Generator: DocBook XSL Stylesheets vsnapshot_2006\-08\-24_0226 <http://docbook.sf.net/>
+.\" Date: 08/31/2006
.\" Manual: Linux\-PAM
.\" Source: Linux\-PAM
.\"
-.TH "PAM_SUCCEED_IF" "8" "08/05/2006" "Linux\-PAM" "Linux\-PAM"
+.TH "PAM_SUCCEED_IF" "8" "08/31/2006" "Linux\-PAM" "Linux\-PAM"
.\" disable hyphenation
.nh
.\" disable justification (adjust text to left margin only)
@@ -101,11 +101,7 @@ User is not in given group.
(user,host) is not in given netgroup.
.SH "MODULE SERVICES PROVIDED"
.PP
-The
-\fBauth\fR
-and
-\fBaccount\fR
-services are supported.
+All services are supported.
.SH "RETURN VALUES"
.TP 3n
PAM_SUCCESS